upgrader 0.5.1+1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 79

Upgrader #

Flutter package for prompting users to upgrade when there is a newer version of the app in the store.

Build Status CircleCI codecov pub package

Become a Patron!

When a newer app version is availabe in the app store, a simple alert prompt widget or card is displayed. With today's modern app stores, there is little need to persuade users to upgrade because most of them are already using the auto upgrade feature. However, there may be times when an app needs to be updated more quickly than usual, and nagging a user to upgrade will entice the upgrade sooner. Also, with Flutter supporting more than just Android and iOS app stores in the future, it will become more likely that users on other app stores need to be nagged about upgrading.

The UI comes in two flavors: alert or card. The UpgradeAlert class is used to display the popup alert prompt, and the UpgradeCard class is used to display the inline material design card.

Alert Example #

Just wrap your body widget in the UpgradeAlert widget, and it will handle the rest.

import 'package:flutter/material.dart';
import 'package:upgrader/upgrader.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  MyApp({
    Key key,
  }) : super(key: key);

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Upgrader Example',
      home: Scaffold(
          appBar: AppBar(
            title: Text('Upgrader Example'),
          ),
          body: UpgradeAlert(
            child: Center(child: Text('Checking...')),
          )
      ),
    );
  }
}

Screenshot of alert #

image

Card Example #

Just return an UpgradeCard widget in your build method and a material design card will be displayed when an update is detected. The widget will have width and height of 0.0 when no update is detected.

return Container(
        margin: EdgeInsets.fromLTRB(12.0, 0.0, 12.0, 0.0),
        child: UpgradeCard());

Screenshot of card #

image

Customization #

The UpgradeAlert widget can be customized by setting parameters in the constructor of the UpgradeAlert widget.

  • appcastConfig: the appcast configuration, defaults to null
  • buttonTitleIgnore: the ignore button title, which defaults to Ignore
  • buttonTitleLater: the later button title, which defaults to Later
  • buttonTitleUpdate: the update button title, which defaults to Update Now
  • client: an HTTP Client that can be replaced for mock testing, defaults to null
  • daysUntilAlertAgain: days until alerting user again, which defaults to 3
  • debugDisplayAlways: always force the upgrade to be available, defaults to false
  • debugDisplayOnce: display the upgrade at least once once, defaults to false
  • debugLogging: display logging statements, which defaults to false
  • onIgnore: Called when the ignore button is tapped, defaults to null
  • onLater: Called when the ignore button is tapped, defaults to null
  • onUpdate: Called when the ignore button is tapped, defaults to null
  • prompt: the call to action message, which defaults to Would you like to update it now?
  • title: the alert dialog title, which defaults to Update App?

Limitations #

These widgets work on both Android and iOS. When running on iOS the App Store will provide the latest app version and will display the prompt at the appropriate times.

On Android, this widget does nothing as there is no easy way to query the Google Play Store for metadata about an app. Without the metadata, the widget cannot compare the app version with the latest Play Store version. It will not disrupt the widget tree and can be included in an Android without any issues.

There is now an appcast that can be used for Android and iOS to remotely configure the latest app version.

Appcast #

The class Appcast, in this Flutter package, is used by the Upgrader widgets to download app details from an appcast, based on the Sparkle framework by Andy Matuschak. You can read the Sparkle documentation here: https://sparkle-project.org/documentation/publishing/.

An appcast is an RSS feed with one channel that has a collection of items that each describe one app version. The appcast will decscribe each app version and will provide the latest app version to Upgrader that indicates when an upgrade should be recommended.

The appcast must be hosted on a server that can be reached by everyone from the app. The appcast XML file can be autogenerated during the release process, or just manually updated after a release is available on the app store.

The Appcast class can be used stand alone or as part of Upgrader.

Appcast Example #

final appcast = Appcast();
final items = await appcast.parseAppcastItemsFromUri('https://raw.githubusercontent.com/larryaasen/upgrader/master/test/testappcast.xml');
final bestItem = appcast.bestItem();

Appcast Sample File #

<?xml version="1.0" encoding="utf-8"?>
<rss version="2.0" xmlns:sparkle="http://www.andymatuschak.org/xml-namespaces/sparkle">
    <channel>
        <title>Debt Now App - Appcast</title>
        <item>
            <title>Version 1.15.0</title>
            <description>desc</description>
            <pubDate>Sun, 30 Dec 2018 12:00:00 +0000</pubDate>
            <enclosure url="https://play.google.com/store/apps/details?id=com.moonwink.treasury" sparkle:version="1.15.0" sparkle:os="android" />
        </item>
    </channel>
</rss>

iTunes Search API #

There is a class in this Flutter package used by the upgrader widgets to download app details from the iTunes Search API. The class ITunesSearchAPI can be used standalone to query iTunes for app details.

ITunesSearchAPI Example #

final iTunes = ITunesSearchAPI();
final resultsFuture = iTunes.lookupByBundleId('com.google.Maps');
resultsFuture.then((results) {
    print('results: $results');
});

Results #

image

Contributing #

All comments and pull requests are welcome.

Become a Patron!

0.5.1+1 #

  • updated the examples with an Appcast for Android.

0.5.1 #

  • downgraded the xml package version to 3.4.0 to be compatible with Dart 2.2, and updated the Dart version to 2.2.0

0.5.0 #

  • Breaking change. Migrate from the deprecated original Android Support Library to AndroidX. This shouldn't result in any functional changes, but it requires any Android apps using this plugin to also migrate if they're using the original support library.

0.4.3 #

  • improved README documentation and example code

0.4.2 #

  • fixed README file that appears on the Dart Packages website

0.4.1 #

  • fixed README file that appears on the Dart Packages website

0.4.0 #

  • added Appcast to support Android upgrades

0.3.0 #

  • added UpgradeCard class

0.2.0 #

  • added many customizations to the widget including callbacks for onIgnore, onLater, and onUpdate
  • updated the README screenshot
  • updated tests, improved README
  • broke out widget into new file

0.1.0 #

  • Initial Open Source release.

example/lib/main.dart

/*
 * Copyright (c) 2019 Larry Aasen. All rights reserved.
 */

import 'package:flutter/material.dart';
import 'package:upgrader/upgrader.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  MyApp({
    Key key,
  }) : super(key: key);

  @override
  Widget build(BuildContext context) {
    // Setup the Appcast for Android only. On iOS, the default behavior will be
    // to use the App Store version of the app.
    final String appcastURL =
        'https://raw.githubusercontent.com/larryaasen/upgrader/master/test/testappcast.xml';
    final cfg = AppcastConfiguration(url: appcastURL, supportedOS: ["android"]);

    return MaterialApp(
      title: 'Upgrader Example',
      home: Scaffold(
          appBar: AppBar(
            title: Text('Upgrader Example'),
          ),
          body: UpgradeAlert(
            appcastConfig: cfg,
            child: Center(child: Text('Checking...')),
          )),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  upgrader: ^0.5.1+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:upgrader/upgrader.dart';
  
Version Uploaded Documentation Archive
0.5.1+1 May 14, 2019 Go to the documentation of upgrader 0.5.1+1 Download upgrader 0.5.1+1 archive
0.5.1 May 8, 2019 Go to the documentation of upgrader 0.5.1 Download upgrader 0.5.1 archive
0.5.0 May 5, 2019 Go to the documentation of upgrader 0.5.0 Download upgrader 0.5.0 archive
0.4.3 Jan 6, 2019 Go to the documentation of upgrader 0.4.3 Download upgrader 0.4.3 archive
0.4.2 Jan 4, 2019 Go to the documentation of upgrader 0.4.2 Download upgrader 0.4.2 archive
0.4.1 Jan 4, 2019 Go to the documentation of upgrader 0.4.1 Download upgrader 0.4.1 archive
0.4.0 Jan 4, 2019 Go to the documentation of upgrader 0.4.0 Download upgrader 0.4.0 archive
0.3.0 Dec 23, 2018 Go to the documentation of upgrader 0.3.0 Download upgrader 0.3.0 archive
0.2.0 Dec 12, 2018 Go to the documentation of upgrader 0.2.0 Download upgrader 0.2.0 archive
0.1.0 Dec 3, 2018 Go to the documentation of upgrader 0.1.0 Download upgrader 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
65
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on Jun 25, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 3 dependencies (1 direct: xml).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
device_info ^0.4.0+1 0.4.0+2
flutter 0.0.0
http ^0.12.0 0.12.0+2
package_info ^0.4.0+3 0.4.0+4
shared_preferences ^0.5.2 0.5.3+1
url_launcher ^5.0.2 5.0.3
version ^1.0.3 1.0.3
xml ^3.4.0 3.4.1 3.5.0
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
pedantic 1.7.0
petitparser 2.2.1 2.3.0
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
mockito ^4.0.0