tweet_ui 3.0.1
tweet_ui: ^3.0.1 copied to clipboard

Show Tweets from a Twitter API JSON on Android and iOS. Support for Tweets with 1-4 photos, Video, GIFs, hashtags, mentions, symbols, urls, quoted Tweets and retweets.

27
likes
120/ 130
pub points
81%
popularity

We analyzed this package on Oct 20, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 144 out of 264 API elements (54.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:tweet_ui/tweet_ui.dart that imports:
  • package:tweet_ui/embedded_tweet_view.dart that imports:
  • package:tweet_ui/src/quote_tweet_view_embedded.dart that imports:
  • package:tweet_ui/src/media_container.dart that imports:
  • package:tweet_ui/src/tweet_video.dart that imports:
  • package:better_player/better_player.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
better_player^0.0.630.0.770.0.77
cached_network_image^3.0.03.1.03.1.0
flutterflutter0.0.00.0.0
html_unescape^2.0.02.0.02.0.0
intl^0.17.00.17.00.17.0
photo_view^0.12.00.12.00.13.0
url_launcher^6.0.26.0.126.0.12
video_player^2.0.22.2.52.2.5
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.2
boolean_selector-2.1.02.1.0
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
csslib-0.17.10.17.1
cupertino_icons-1.0.31.0.3
fake_async-1.2.01.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.1.23.1.2
flutter_web_plugins-0.0.00.0.0
flutter_widget_from_html_core-0.7.00.8.0
html-0.15.00.15.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
matcher-0.12.100.12.11
meta-1.7.01.7.0
octo_image-1.0.0+11.0.0+1
path-1.8.01.8.0
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
rxdart-0.27.20.27.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
test_api-0.4.20.4.5
typed_data-1.3.01.3.0
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.42.0.4
url_launcher_windows-2.0.22.0.2
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
video_player_platform_interface-4.2.04.2.0
video_player_web-2.0.42.0.4
visibility_detector-0.2.20.2.2
wakelock-0.5.60.5.6
wakelock_macos-0.4.00.4.0
wakelock_platform_interface-0.3.00.3.0
wakelock_web-0.4.00.4.0
wakelock_windows-0.2.00.2.0
win32-2.2.102.2.10
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on photo_view does not support the stable version `0.13.0`, that was published 14 days ago.

When photo_view is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions photo_view to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

27
likes
120
pub points
81%
popularity

Show Tweets from a Twitter API JSON on Android and iOS. Support for Tweets with 1-4 photos, Video, GIFs, hashtags, mentions, symbols, urls, quoted Tweets and retweets.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

better_player, cached_network_image, flutter, html_unescape, intl, photo_view, url_launcher, video_player

More

Packages that depend on tweet_ui