tivio_sdk 1.4.0
tivio_sdk: ^1.4.0 copied to clipboard

Tivio Flutter SDK

0
likes
90 / 130
pub points
52 %
popularity

We analyzed this package on Jun 23, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://tiv.io was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 413 API elements (6.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:tivio_sdk/bridge.dart that imports:
  • package:tivio_sdk/logger.dart that imports:
  • package:tivio_sdk/tivio.dart that imports:
  • package:tivio_sdk/player/tivio_player.dart that imports:
  • package:tivio_sdk/player/controls/better_player_custom_controls.dart that imports:
  • package:tivio_sdk/player/controls/better_player_control.dart that imports:
  • package:tivio_sdk/player/controls/better_player_material_progress_bar.dart that imports:
  • package:better_player/src/video_player/video_player_platform_interface.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

lib/bridge.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/dto.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
better_player^0.0.680.0.700.0.70
flutterflutter0.0.00.0.0
flutter_svg^0.22.00.22.00.22.0
interactive_webview_null_safety^0.2.40.2.40.2.4
logger^1.0.01.0.01.0.0
sentry^5.0.05.1.05.1.0
sentry_flutter^5.0.05.1.05.1.0
uuid^3.0.43.0.43.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.7.02.7.0
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
csslib-0.17.00.17.0
cupertino_icons-1.0.31.0.3
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
flutter_widget_from_html_core-0.6.1+30.6.1+3
html-0.15.00.15.0
http-0.13.30.13.3
http_parser-4.0.04.0.0
js-0.6.30.6.3
meta-1.3.01.4.0
package_info_plus-1.0.31.0.3
package_info_plus_linux-1.0.21.0.2
package_info_plus_macos-1.1.11.1.1
package_info_plus_platform_interface-1.0.11.0.1
package_info_plus_web-1.0.21.0.2
package_info_plus_windows-1.0.21.0.2
path-1.8.01.8.0
path_drawing-0.5.10.5.1
path_parsing-0.2.10.2.1
path_provider-2.0.22.0.2
path_provider_linux-2.0.02.0.0
path_provider_macos-2.0.02.0.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.12.0.1
pedantic-1.11.11.11.1
petitparser-4.1.04.2.0
platform-3.0.03.0.0
plugin_platform_interface-2.0.02.0.0
process-4.2.14.2.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
visibility_detector-0.2.00.2.0
wakelock-0.5.20.5.2
wakelock_macos-0.1.0+10.1.0+1
wakelock_platform_interface-0.2.1+10.2.1+1
wakelock_web-0.2.0+10.2.0+1
wakelock_windows-0.1.00.1.0
win32-2.2.32.2.3
xdg_directories-0.2.00.2.0
xml-5.1.25.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.