mmoo_base 1.1.0-dev.4
mmoo_base: ^1.1.0-dev.4 copied to clipboard

A Flutter base module.

1
likes
70/ 130
pub points
0%
popularity

We analyzed this package on Oct 18, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/seemelala/flutter_base was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 322 out of 2293 API elements (14.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `iOS`.

Because:

  • package:mmoo_base/api/api.dart that imports:
  • package:mmoo_base/dao/base_dao.dart that imports:
  • package:sp_util/sp_util.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 42 issues. Showing the first 2:

lib/dao/base_dao.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/entity/admob_config_entity.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
android_intent^2.0.22.0.22.0.2
connectivity^3.0.63.0.63.0.6
crypto^3.0.13.0.13.0.1
date_format^2.0.42.0.42.0.4
device_info^2.0.22.0.22.0.2
dio^4.0.04.0.04.0.0
encrypt^5.0.15.0.15.0.1
flutterflutter0.0.00.0.0
flutter_cache_manager^3.1.23.1.23.1.2
flutter_image_compress^1.0.11.1.01.1.0
flutter_screenutil^5.0.0+25.0.0+25.0.0+2
flutter_secure_storage^4.2.14.2.14.2.1
intl^0.17.00.17.00.17.0
meta^1.3.01.7.01.7.0
package_info^2.0.22.0.22.0.2
path_provider^2.0.52.0.52.0.5
permission_handler^8.2.28.2.58.2.5
sp_util^2.0.32.0.32.0.3
sqflite^2.0.0+42.0.0+42.0.0+4
sqflite_common^2.0.1+12.0.1+12.0.1+1
vibration^1.7.4-nullsafety.01.7.4-nullsafety.01.7.4-nullsafety.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
asn1lib-1.0.21.0.2
async-2.8.22.8.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
connectivity_for_web-0.4.0+10.4.0+1
connectivity_macos-0.2.1+20.2.1+2
connectivity_platform_interface-2.0.12.0.1
convert-3.0.13.0.1
device_info_platform_interface-2.0.12.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
path-1.8.01.8.0
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
permission_handler_platform_interface-3.7.03.7.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
pointycastle-3.3.43.3.4
process-4.2.44.2.4
rxdart-0.27.20.27.2
shared_preferences-2.0.82.0.8
shared_preferences_linux-2.0.22.0.2
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.22.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
vibration_web-1.6.3-nullsafety.01.6.3-nullsafety.0
win32-2.2.92.2.9
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.