flutter_chat 2.1.0
flutter_chat: ^2.1.0 copied to clipboard

Messaging app for Flutter android , iOS and flutter-web using firebase as backend services.

64
likes
90/ 130
pub points
77%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/flutter_chat.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 116 API elements (7.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:flutter_chat/chatData.dart that imports:
  • package:flutter_chat/screens/login_screen.dart that imports:
  • package:flutter_chat/chatWidget.dart that imports:
  • package:cached_network_image/cached_network_image.dart that imports:
  • package:cached_network_image/src/image_provider/cached_network_image_provider.dart that imports:
  • package:cached_network_image_web/cached_network_image_web.dart that imports:
  • package:flutter_cache_manager/flutter_cache_manager.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/cache_info_repositories.dart that imports:
  • package:flutter_cache_manager/src/storage/cache_info_repositories/json_cache_info_repository.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/chatDB.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^3.0.03.1.03.1.0
cloud_firestore^2.2.22.5.32.5.3
cupertino_icons^1.0.31.0.31.0.3
firebase_auth^1.4.11.4.13.1.3
firebase_core^1.3.01.7.01.7.0
firebase_messaging^10.0.210.0.810.0.8
firebase_storage^8.1.38.1.310.0.5
flutterflutter0.0.00.0.0
flutter_linkify^5.0.25.0.25.0.2
flutter_local_notifications^5.0.0+45.0.0+49.0.0
flutter_native_image^0.0.60.0.6+10.0.6+1
google_sign_in^5.0.45.1.15.1.1
http^0.13.30.13.40.13.4
image_picker^0.8.0+30.8.4+20.8.4+2
image_picker_for_web^2.0.02.1.32.1.3
intl^0.17.00.17.00.17.0
path^1.8.01.8.01.8.0
photo_view^0.11.10.11.10.13.0
shared_preferences^2.0.62.0.82.0.8
url_launcher^6.0.66.0.126.0.12
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
cloud_firestore_platform_interface-5.4.25.4.2
cloud_firestore_web-2.4.32.4.3
collection-1.15.01.15.0
cross_file-0.3.1+50.3.1+5
crypto-3.0.13.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase_auth_platform_interface-4.3.16.1.1
firebase_auth_web-1.3.13.1.2
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
firebase_messaging_platform_interface-3.0.63.0.6
firebase_messaging_web-2.0.62.0.6
firebase_storage_platform_interface-2.1.24.0.3
firebase_storage_web-1.1.23.0.3
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.1.23.1.2
flutter_local_notifications_platform_interface-3.0.05.0.0
flutter_plugin_android_lifecycle-2.0.32.0.3
flutter_web_plugins-0.0.00.0.0
google_sign_in_platform_interface-2.1.02.1.0
google_sign_in_web-0.10.0+30.10.0+3
http_parser-4.0.04.0.0
image_picker_platform_interface-2.4.12.4.1
js-0.6.30.6.3
linkify-4.1.04.1.0
matcher-0.12.110.12.11
meta-1.7.01.7.0
octo_image-1.0.0+11.0.0+1
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.34.2.3
quiver-3.0.1+13.0.1+1
rxdart-0.27.20.27.2
shared_preferences_linux-2.0.22.0.2
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.22.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
timezone-0.7.00.8.0
typed_data-1.3.01.3.0
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.42.0.4
url_launcher_windows-2.0.22.0.2
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
win32-2.2.92.2.9
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.4.1` on firebase_auth does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions firebase_auth to update the constraint.

The constraint `^8.1.3` on firebase_storage does not support the stable version `9.0.0`.

Try running dart pub upgrade --major-versions firebase_storage to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.