carp_audio_package 0.31.0
carp_audio_package: ^0.31.0 copied to clipboard

CARP Audio Sampling Package. Samples audio recording and noise.

0
likes
120/ 130
pub points
66%
popularity

We analyzed this package on Oct 15, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 53 out of 71 API elements (74.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:carp_audio_package/audio.dart that imports:
  • package:carp_mobile_sensing/carp_mobile_sensing.dart that imports:
  • package:carp_mobile_sensing/sampling_packages/sensors/sensors.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
carp_core^0.31.00.31.00.31.0
carp_mobile_sensing^0.31.00.31.00.31.0
flutterflutter0.0.00.0.0
flutter_sound^8.1.48.4.1+18.4.1+1
json_annotation^4.0.14.3.04.3.0
noise_meter^3.0.33.0.33.0.3
permission_handler>=8.1.0 <8.2.08.1.68.2.5
stats^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
args-2.3.02.3.0
async-2.8.22.8.2
audio_streamer-2.0.32.0.3
battery_plus-2.0.12.0.1
battery_plus_linux-1.0.31.0.3
battery_plus_macos-1.0.21.0.2
battery_plus_platform_interface-1.1.01.1.0
battery_plus_web-1.0.21.0.2
battery_plus_windows-1.0.21.0.2
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
cron-0.3.20.3.2
crypto-3.0.13.0.1
dbus-0.5.60.6.3
device_info_plus-3.1.03.1.0
device_info_plus_linux-2.1.02.1.0
device_info_plus_macos-2.2.02.2.0
device_info_plus_platform_interface-2.2.02.2.0
device_info_plus_web-2.1.02.1.0
device_info_plus_windows-2.1.02.1.0
ffi-1.1.21.1.2
file-6.1.26.1.2
file_utils-1.0.11.0.1
flutter_local_notifications-8.2.09.0.0
flutter_local_notifications_platform_interface-4.0.15.0.0
flutter_sound_platform_interface-8.4.18.4.1
flutter_sound_web-8.4.18.4.1
flutter_web_plugins-0.0.00.0.0
globbing-1.0.01.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.30.6.3
light-2.1.02.1.0
logger-1.1.01.1.0
meta-1.7.01.7.0
nested-1.0.01.0.0
package_info_plus-1.3.01.3.0
package_info_plus_linux-1.0.31.0.3
package_info_plus_macos-1.3.01.3.0
package_info_plus_platform_interface-1.0.21.0.2
package_info_plus_web-1.0.41.0.4
package_info_plus_windows-1.0.41.0.4
path-1.8.01.8.0
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
pedometer-3.0.03.0.0
permission_handler_platform_interface-3.7.03.7.0
petitparser-4.3.04.3.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.22.0.2
process-4.2.34.2.3
provider-6.0.16.0.1
recase-4.0.04.0.0
screen_state-2.0.02.0.0
sensors_plus-1.2.11.2.1
sensors_plus_platform_interface-1.1.01.1.0
sensors_plus_web-1.1.01.1.0
shared_preferences-2.0.82.0.8
shared_preferences_linux-2.0.22.0.2
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.22.0.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
system_info-1.0.11.0.1
term_glyph-1.2.01.2.0
timezone-0.8.00.8.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
win32-2.2.92.2.9
xdg_directories-0.2.00.2.0
xml-5.3.05.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=8.1.0 <8.2.0` on permission_handler does not support the stable version `8.2.0`, that was published 10 days ago.

When permission_handler is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.