bones_ui_bootstrap 2.0.2
bones_ui_bootstrap: ^2.0.2 copied to clipboard

Adds Bootstrap 4+ support to Dart package bones_ui, allowing use of Bootstrap components and CSS.

6
likes
120 / 130
pub points
19 %
popularity

We analyzed this package on Jun 21, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 51 out of 94 API elements (54.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:bones_ui_bootstrap/bones_ui_bootstrap.dart that imports:
  • package:bones_ui_bootstrap/src/components/daterangepicker.dart that imports:
  • package:bones_ui_bootstrap/src/bones_ui_bootstrap_base.dart that imports:
  • package:bones_ui/bones_ui_kit.dart that imports:
  • package:bones_ui/bones_ui.dart that imports:
  • package:bones_ui/src/component/svg.dart that imports:
  • package:dom_tools/dom_tools.dart that imports:
  • package:dom_tools/src/perspective_filter.dart that imports:
  • package:dom_tools/src/dom_tools_paint.dart that imports:
  • dart:html
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
amdjs^2.0.12.0.12.0.1
bones_ui^2.0.22.0.22.0.2
dom_tools^2.0.12.0.12.0.1
intl_messages^2.0.12.0.12.0.1
swiss_knife^3.0.73.0.73.0.7
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.23.1.2
args-2.1.12.1.1
charcode-1.3.11.3.1
chart_engine-2.0.22.0.2
clock-1.1.01.1.0
collection-1.15.01.15.0
color_palette_generator-2.0.02.0.0
crypto-3.0.13.0.1
csslib-0.17.00.17.0
dom_builder-2.0.22.0.2
dynamic_call-2.0.12.0.1
enum_to_string-2.0.12.0.1
expressions-0.2.20.2.2
fake_async-1.2.01.2.0
html-0.15.00.15.0
html_unescape-2.0.02.0.0
intl-0.17.00.17.0
json_object_mapper-2.0.12.0.1
json_render-2.0.12.0.1
markdown-4.0.04.0.0
matcher-0.12.100.12.10
mercury_client-2.0.32.0.3
meta-1.4.01.4.0
path-1.8.01.8.0
petitparser-4.2.04.2.0
quiver-3.0.13.0.1
resource_portable-3.0.03.0.0
rxdart-0.26.00.27.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.18.2, Dart 2.13.3.

6
likes
120
pub points
19%
popularity

Publisher

Unknown

Adds Bootstrap 4+ support to Dart package bones_ui, allowing use of Bootstrap components and CSS.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

amdjs, bones_ui, dom_tools, intl_messages, swiss_knife

More

Packages that depend on bones_ui_bootstrap