webdev 2.7.6
webdev: ^2.7.6 copied to clipboard

A CLI for Dart web development. Provides an easy and consistent set of features for users and tools to build and deploy web applications with Dart.

24
likes
90/ 130
pub points
71%
popularity

We analyzed this package on Nov 30, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^2.0.02.3.02.3.0
async^2.2.02.8.22.8.2
browser_launcher^1.0.01.0.01.0.0
build_daemon>=2.0.0 <4.0.03.0.13.0.1
crypto^3.0.03.0.13.0.1
dds^2.0.02.1.42.1.4
devtools^2.0.02.8.02.8.0
devtools_server^2.0.02.8.02.8.0
dwds^11.3.011.4.011.4.0
http^0.13.00.13.40.13.4
http_multi_server^3.0.03.0.13.0.1
io^1.0.01.0.31.0.3
logging^1.0.01.0.21.0.2
meta^1.1.21.7.01.7.0
path^1.5.11.8.01.8.0
pedantic^1.5.01.11.11.11.1
pool^1.4.01.5.01.5.0
pub_semver^2.0.02.1.02.1.0
pubspec_parse^1.0.01.1.01.1.0
shelf^1.0.01.2.01.2.0
shelf_proxy^1.0.01.0.11.0.1
shelf_static^1.0.01.1.01.1.0
sse^4.1.04.1.04.1.0
vm_service>=3.0.0 <8.0.07.3.07.5.0
webkit_inspection_protocol>=0.4.0 <2.0.01.0.01.0.0
yaml^3.0.03.1.03.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
built_collection-5.1.15.1.1
built_value-8.1.38.1.3
charcode-1.3.11.3.1
checked_yaml-2.0.12.0.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-3.0.13.0.1
devtools_shared-2.8.02.8.0
fixnum-1.0.01.0.0
http_parser-4.0.04.0.0
intl-0.17.00.17.0
json_annotation-4.3.04.3.0
json_rpc_2-3.0.13.0.1
mime-1.0.11.0.1
package_config-2.0.22.0.2
shelf_packages_handler-3.0.03.0.0
shelf_web_socket-1.0.11.0.1
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
usage-4.0.24.0.2
watcher-1.0.11.0.1
web_socket_channel-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Package is not null safe

Because:

  • webdev that depends on:
  • devtools that doesn't opt in to null safety
For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.21.4, Dart 2.14.4.

24
likes
90
pub points
71%
popularity

Publisher

tools.dart.dev

A CLI for Dart web development. Provides an easy and consistent set of features for users and tools to build and deploy web applications with Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

args, async, browser_launcher, build_daemon, crypto, dds, devtools, devtools_server, dwds, http, http_multi_server, io, logging, meta, path, pedantic, pool, pub_semver, pubspec_parse, shelf, shelf_proxy, shelf_static, sse, vm_service, webkit_inspection_protocol, yaml

More

Packages that depend on webdev