dds 1.2.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 76

A package used to spawn the Dart Developer Service (DDS), which is used to communicate with a Dart VM Service instance and provide extended functionality to the core VM Service Protocol.

Functionality #

Existing VM Service clients can issue both HTTP and websocket requests to a running DDS instance as if it were an instance of the VM Service itself. If a request corresponds to an RPC defined in the VM Service Protocol, DDS will forward the request and return the response from the VM Service. Requests corresponding to an RPC defined in the DDS Protocol will be handled directly by the DDS instance.

1.2.1 #

  • Fixed issue where evaluate and evaluateInFrame were not invoking client provided implementations of compileExpression.

1.2.0 #

  • Fixed issue where forwarding requests with no RPC parameters would return an RPC error.

1.1.0 #

  • Added getDartDevelopmentServiceVersion RPC.
  • Added DDS protocol to VM service getSupportedProtocols response.
  • Added example/example.dart.
  • Allow for JSON-RPC 2.0 requests which are missing the jsonrpc parameter.

1.0.0 #

  • Initial release.

example/example.dart

// Copyright (c) 2020, the Dart project authors.  Please see the AUTHORS file
// for details. All rights reserved. Use of this source code is governed by a
// BSD-style license that can be found in the LICENSE file.

import 'package:dds/dds.dart';
import 'package:vm_service/vm_service_io.dart';

import '../test/common/test_helper.dart';

Future<void> main() async {
  final process = await spawnDartProcess('../test/smoke.dart');
  final dds = await DartDevelopmentService.startDartDevelopmentService(
    remoteVmServiceUri,
  );

  // Connect to the DDS instance and make a request using package:vm_service.
  final service = await vmServiceConnectUri(dds.wsUri.toString());
  final version = await service.getVersion();

  print('Service Version: $version');

  await dds.shutdown();
  process.kill();
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dds: ^1.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dds/dds.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
51
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
76
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15

Analysis suggestions

Package not compatible with runtime flutter-web on Web

Because:

  • package:dds/dds.dart that imports:
  • package:shelf/shelf_io.dart that imports:
  • package:shelf/src/io_server.dart that imports:
  • dart:io

Package not compatible with runtime js

Because:

  • package:dds/dds.dart that imports:
  • package:shelf/shelf_io.dart that imports:
  • package:shelf/src/io_server.dart that imports:
  • dart:io

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
async ^2.4.1 2.4.2
json_rpc_2 ^2.2.0 2.2.1
meta ^1.1.8 1.2.2 1.3.0-nullsafety
pedantic ^1.7.0 1.9.2
shelf ^0.7.5 0.7.7
shelf_proxy ^0.1.0+7 0.1.0+7
shelf_web_socket ^0.2.3 0.2.3
stream_channel ^2.0.0 2.0.0
web_socket_channel ^1.1.0 1.1.0
Transitive dependencies
charcode 1.1.3
collection 1.14.13 1.15.0-nullsafety
convert 2.1.1
crypto 2.1.5
http 0.12.1
http_parser 3.1.4
path 1.7.0
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0 1.3.0-nullsafety
Dev dependencies
test ^1.0.0
vm_service ^4.0.0