dwds 0.3.3

Dart Web Developer Service

Note: Under heavy development.

The Dart Web Developer Service (DWDS) allows developer tools designed to work with the native Dart VM to also work with Dart Web applications compiled with DDC, built/served with webdev, and run in Chrome.

DWDS will be integrated into the webdev.

At a basic level, DWDS proxies between:

0.3.3 #

  • Add support for getScript for paused isolates.
  • Add support for onRequest and onResponse listeners for the vm service.

0.3.2 #

  • Add support for scope in evaluate calls.

0.3.1 #

  • Improve error reporting for evals, give the full JS eval in the error message so it can be more easily reproduced.

0.3.0 #

  • Change the exposed type on DebugService to VmServiceInterface

0.2.1 #

  • Support setExceptionPauseMode.

0.2.0 #

  • Added custom tokens to the wsUri for increased security.
    • Treating this as a breaking change because you now must use the wsUri getter to get a valid uri for connecting to the service, when previously combining the port and host was sufficient.

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  dwds: ^0.3.3

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dwds/service.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19


Detected platforms: Flutter, other

Platform components identified in package: io.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (vm_service_lib).

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and dwds.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
http ^0.12.0 0.12.0+2
http_multi_server ^2.0.0 2.1.0
path ^1.6.0 1.6.2
pedantic ^1.5.0 1.8.0+1
pub_semver ^1.4.2 1.4.2
shelf ^0.7.0 0.7.5
shelf_web_socket ^0.2.0 0.2.3
source_maps ^0.10.0 0.10.8
vm_service_lib 3.17.0+1 3.17.0+1 3.22.1
web_socket_channel ^1.0.0 1.0.14
webkit_inspection_protocol ^0.4.0 0.4.2
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
http_parser 3.1.3
logging 0.11.3+2
meta 1.1.7
source_span 1.5.5
stack_trace 1.9.3
stream_channel 2.0.0
stream_transform 0.0.19
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
args ^1.0.0 1.5.2
build_runner ^1.0.0
build_web_compilers >=1.0.0 <3.0.0
test ^1.6.0
webdev ^2.0.0
webdriver ^2.0.0