rapidoc_utils 0.0.11 icon indicating copy to clipboard operation
rapidoc_utils: ^0.0.11 copied to clipboard

Some common used classes

0
likes
70/ 130
pub points
11%
popularity

We analyzed this package 13 hours ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://rapidoc.app was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 23 out of 349 API elements (6.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:rapidoc_utils/routes/image_file_preview.dart that imports:
  • package:image_cropper/image_cropper.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:rapidoc_utils/routes/image_file_preview.dart that imports:
  • package:image_cropper/image_cropper.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:rapidoc_utils/routes/image_file_preview.dart that imports:
  • package:image_cropper/image_cropper.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:rapidoc_utils/routes/image_file_preview.dart that imports:
  • package:image_cropper/image_cropper.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:rapidoc_utils/utils/Utils.dart that imports:
  • package:geolocator/geolocator.dart that imports:
  • package:geolocator_apple/geolocator_apple.dart that declares support for platforms: iOS, macOS.
Package does not support platform `iOS`.

Because:

  • package:rapidoc_utils/utils/Utils.dart that imports:
  • package:geolocator/geolocator.dart that imports:
  • package:geolocator_android/geolocator_android.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: Instance member 'cropImage' can't be accessed using static access.

lib/routes/image_file_preview.dart:108:46

    ╷
108 │       File? croppedFile = await ImageCropper.cropImage(
    │                                              ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/routes/image_file_preview.dart

INFO: 'getImage' is deprecated and shouldn't be used. Switch to using pickImage instead.

lib/utils/Utils.dart:53:26

   ╷
53 │     var image = await ip.getImage(source: source);
   │                          ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/utils/Utils.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dio^4.0.04.0.64.0.6
flutterflutter0.0.00.0.0
flutter_responsive_tools^0.0.10.0.10.0.1
geolocator^8.0.18.2.18.2.1
http_error_handler^0.0.10.0.10.0.1
image_cropper^1.4.11.5.12.0.3
image_picker^0.8.4+30.8.5+30.8.5+3
photo_view^0.13.00.13.00.13.0
rxdart^0.27.10.27.30.27.3
shared_preferences^2.0.62.0.152.0.15
universal_html^2.0.82.0.82.0.8
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.9.02.9.0
characters-1.2.01.2.1
charcode-1.3.11.3.1
collection-1.16.01.16.0
cross_file-0.3.30.3.3
crypto-3.0.23.0.2
csslib-0.17.10.17.1
ffi-1.2.11.2.1
file-6.1.26.1.2
flutter_plugin_android_lifecycle-2.0.62.0.6
flutter_web_plugins-0.0.00.0.0
geolocator_android-3.1.83.1.8
geolocator_apple-2.1.32.1.3
geolocator_platform_interface-4.0.54.0.5
geolocator_web-2.1.52.1.5
geolocator_windows-0.1.10.1.1
html-0.15.00.15.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
image_picker_android-0.8.4+130.8.4+13
image_picker_for_web-2.1.82.1.8
image_picker_ios-0.8.5+40.8.5+4
image_picker_platform_interface-2.5.02.5.0
js-0.6.40.6.4
material_color_utilities-0.1.40.1.5
meta-1.7.01.7.0
path-1.8.11.8.1
path_provider_linux-2.1.62.1.6
path_provider_platform_interface-2.0.42.0.4
path_provider_windows-2.0.62.0.6
platform-3.1.03.1.0
plugin_platform_interface-2.1.22.1.2
process-4.2.44.2.4
shared_preferences_android-2.0.122.0.12
shared_preferences_ios-2.1.12.1.1
shared_preferences_linux-2.1.12.1.1
shared_preferences_macos-2.0.42.0.4
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.12.1.1
sky_engine-0.0.990.0.99
source_span-1.9.01.9.0
string_scanner-1.1.11.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
universal_io-2.0.42.0.4
vector_math-2.1.22.1.2
win32-2.6.12.6.1
xdg_directories-0.2.0+10.2.0+1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.4.1` on image_cropper does not support the stable version `2.0.0`, that was published 19 days ago.

When image_cropper is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions image_cropper to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Flutter 3.0.0, Dart 2.17.0.