rapid_widgets_library 0.2.44
rapid_widgets_library: ^0.2.44 copied to clipboard

flutter_catalogue_widgets,FlutterCatalogueWidgets,Flutter widgets,Flutter custom widgets,Flutter package,Flutter widgets package,Flutter custom widgets package,Custom widgets

12
likes
80/ 130
pub points
14%
popularity

We analyzed this package 42 hours ago, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 1380 out of 3011 API elements (45.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:rapid_widgets_library/custom-camera.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 33 issues. Showing the first 2:

lib/CustomListingWidget.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/Dialogs.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^3.0.03.2.03.2.0
carousel_slider^4.0.04.0.04.0.0
charts_flutter^0.12.00.12.00.12.0
chewie^1.0.01.2.21.2.2
cupertino_icons^1.0.01.0.41.0.4
dio^4.0.04.0.44.0.4
file_picker^3.0.33.0.44.2.7
flutterflutter0.0.00.0.0
flutter_clean_calendar^1.1.01.1.01.1.0
flutter_form_builder^6.0.16.2.07.0.0
flutter_mobx^2.0.02.0.22.0.2
flutter_plugin_android_lifecycle^2.0.12.0.52.0.5
flutter_rating_bar^4.0.04.0.04.0.0
fluttertoast^8.0.88.0.88.0.8
font_awesome_flutter^9.2.09.2.09.2.0
get_it^7.1.37.2.07.2.0
http^0.13.30.13.40.13.4
image_picker^0.7.5+20.7.5+40.8.4+4
local_auth^1.1.51.1.81.1.8
mobx^2.0.12.0.52.0.5
path^1.6.41.8.01.8.0
path_provider^2.0.12.0.72.0.7
permission_handler^8.3.08.3.08.3.0
permission_handler_platform_interface^3.7.03.7.03.7.0
pin_code_fields^7.3.07.3.07.3.0
plugin_platform_interface^2.0.22.0.22.0.2
provider^5.0.05.0.06.0.1
quiver^2.1.32.1.53.0.1+1
razorpay_flutter^1.2.71.2.71.2.7
responsive_grid^2.0.02.0.02.0.0
shared_preferences^2.0.52.0.92.0.9
smooth_page_indicator^1.0.0+21.0.0+21.0.0+2
url_launcher^6.0.36.0.176.0.17
video_player^2.1.12.2.72.2.7
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.2
boolean_selector-2.1.02.1.0
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
charts_common-0.12.00.12.0
clock-1.1.01.1.0
collection-1.15.01.15.0
cross_file-0.3.20.3.2
crypto-3.0.13.0.1
csslib-0.17.10.17.1
eventify-1.0.01.0.0
fake_async-1.2.01.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.3.03.3.0
flutter_localizations-0.0.00.0.0
flutter_web_plugins-0.0.00.0.0
html-0.15.00.15.0
http_parser-4.0.04.0.0
image_picker_for_web-2.1.42.1.4
image_picker_platform_interface-2.4.12.4.1
intl-0.17.00.17.0
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.100.12.11
meta-1.7.01.7.0
nested-1.0.01.0.0
octo_image-1.0.11.0.1
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.42.0.4
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
platform-3.1.03.1.0
process-4.2.44.2.4
rxdart-0.27.30.27.3
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.12.0.1
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
test_api-0.4.20.4.8
typed_data-1.3.01.3.0
url_launcher_android-6.0.136.0.13
url_launcher_ios-6.0.136.0.13
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.52.0.5
url_launcher_windows-2.0.22.0.2
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
video_player_platform_interface-4.2.04.2.0
video_player_web-2.0.42.0.4
wakelock-0.5.60.5.6
wakelock_macos-0.4.00.4.0
wakelock_platform_interface-0.3.00.3.0
wakelock_web-0.4.00.4.0
wakelock_windows-0.2.00.2.0
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^3.0.3` on file_picker does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions file_picker to update the constraint.

The constraint `^6.0.1` on flutter_form_builder does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions flutter_form_builder to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.