payment_lib 0.0.4+8 copy "payment_lib: ^0.0.4+8" to clipboard
payment_lib: ^0.0.4+8 copied to clipboard

Flutter Widgets that make it easy to implement Payment Lib to your Flutter App.

2
likes
55/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 55 pub points (of a possible 140):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Repository URL doesn't exist.

At the time of the analysis https://gitlab.com/varx-mobile-dev/payment-lib was unreachable. Make sure that the website is reachable via HEAD requests.

Issue tracker URL doesn't exist.

At the time of the analysis https://gitlab.com/varx-mobile-dev/payment-lib/-/issues was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: payment_lib,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 image link is insecure.

README.md:97:73

   ╷
97 │         <a href = "https://www.linkedin.com/in/zian-fahrudy-969228163/"><img src = "http://www.iconninja.com/files/863/607/751/network-linkedin-social-connection-circular-circle-media-icon.svg" width="18" height="18"/></a>
   │                                                                         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

6 out of 43 API elements (14.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: payment_lib, payment_lib.ButtonType, payment_lib.ButtonType.ButtonType, payment_lib.PaymentInstructionCard, payment_lib.PaymentInstructionCard.PaymentInstructionCard.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 33 issues. Showing the first 2:

ERROR: The named parameter 'primary' isn't defined.

lib/src/payment_summary/payment_summary_type_one.dart:95:19

   ╷
95 │                   primary: buttonColor,
   │                   ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/payment_summary/payment_summary_type_one.dart

INFO: 'bodyText2' is deprecated and shouldn't be used. Use bodyMedium instead. This feature was deprecated after v3.1.0-0.0.pre.

lib/src/payment_instructions/payment_instructions_card.dart:34:32

   ╷
34 │                               .bodyText2!
   │                                ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/payment_instructions/payment_instructions_card.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
fluentui_system_icons ^1.1.153 1.1.236 1.1.236
flutter flutter 0.0.0 0.0.0
flutter_html ^2.2.1 2.2.1 2.2.1
get ^4.6.1 4.6.6 4.6.6
intl ^0.17.0 0.17.0 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
chewie - 1.5.0 1.8.1
chewie_audio - 1.5.0 1.5.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
csslib - 0.17.3 1.0.0
cupertino_icons - 1.0.8 1.0.8
ffi - 2.1.2 2.1.2
flutter_layout_grid - 1.0.6 2.0.6
flutter_math_fork - 0.5.0 0.7.2
flutter_svg - 0.23.0+1 2.0.10+1
flutter_web_plugins - 0.0.0 0.0.0
html - 0.15.4 0.15.4
js - 0.6.7 0.7.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nested - 1.0.0 1.0.0
numerus - 1.1.1 2.2.0
path - 1.9.0 1.9.0
path_drawing - 0.5.1+1 1.0.1
path_parsing - 0.2.1 1.0.1
petitparser - 5.4.0 6.0.2
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
quiver - 3.2.1 3.2.1
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.1
tuple - 2.0.2 2.0.2
vector_math - 2.1.4 2.1.4
video_player - 2.8.6 2.8.6
video_player_android - 2.4.14 2.4.14
video_player_avfoundation - 2.5.7 2.5.7
video_player_platform_interface - 6.2.2 6.2.2
video_player_web - 2.3.0 2.3.0
wakelock - 0.6.2 0.6.2
wakelock_macos - 0.4.0 0.4.0
wakelock_platform_interface - 0.3.0 0.3.0
wakelock_web - 0.4.0 0.4.0
wakelock_windows - 0.2.1 0.2.1
web - 0.5.1 0.5.1
webview_flutter - 2.8.0 4.7.0
webview_flutter_android - 2.10.4 3.16.0
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.13.0
win32 - 3.1.4 5.4.0
xml - 5.4.1 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

2
likes
55
pub points
0%
popularity

Publisher

verified publishervarx.id

Flutter Widgets that make it easy to implement Payment Lib to your Flutter App.

Homepage
Repository (GitLab)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

fluentui_system_icons, flutter, flutter_html, get, intl

More

Packages that depend on payment_lib