nylo_framework 0.4.0
nylo_framework: ^0.4.0 copied to clipboard

Flutter Android iOS

Micro-framework for Flutter that's built to simplify app development for Flutter projects.

5
likes
80 / 110
pub points
23 %
popularity

We analyzed this package on Jan 21, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 62 out of 216 API elements (28.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:nylo_framework/nylo_framework.dart that imports:
  • package:nylo_framework/theme/helper/theme_helper.dart that imports:
  • package:dynamic_theme/dynamic_theme.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'List' is deprecated and shouldn't be used.

lib/metro/models/ny_api_request.dart:22:21

   ╷
22 │       headers = new List<Headers>();
   │                     ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/metro/models/ny_api_request.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.6.01.6.01.6.0
connectivity^0.4.9+20.4.9+52.0.2
dynamic_theme^1.0.11.0.11.0.1
flutter_dotenv^2.1.02.1.03.1.0
flutter_launcher_icons^0.8.00.8.10.8.1
flutter_secure_storage^3.3.33.3.53.3.5
http^0.12.20.12.20.12.2
json_to_dart^1.0.41.0.41.0.4
logger^0.9.20.9.40.9.4
queue^2.0.52.0.7+22.0.7+2
sailor^0.7.10.7.10.7.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.014.0.0
analyzer-0.41.20.41.2
archive-2.0.132.0.13
async-2.4.22.5.0-nullsafety.3
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
cli_util-0.2.00.2.0
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
connectivity_for_web-0.3.1+40.3.1+4
connectivity_macos-0.1.0+70.1.0+7
connectivity_platform_interface-1.0.61.0.6
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart_style-1.3.111.3.11
ffi-0.1.30.1.3
file-5.2.15.2.1
glob-1.2.01.2.0
grapheme_splitter-1.0.01.0.0
http_parser-3.1.43.1.4
image-2.1.192.1.19
intl-0.16.10.16.1
js-0.6.3-nullsafety.30.6.3-nullsafety.3
json_ast-1.0.51.0.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
path-1.7.01.8.0-nullsafety.3
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
pub_semver-1.4.41.4.4
shared_preferences-0.5.12+40.5.12+4
shared_preferences_linux-0.0.2+40.0.2+4
shared_preferences_macos-0.0.1+110.0.1+11
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.2+20.0.2+2
source_span-1.7.01.8.0-nullsafety.4
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
watcher-0.9.7+150.9.7+15
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2
xml-4.5.14.5.1
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.9+2` on connectivity does not support the latest published version `2.0.2`

pubspec.yaml:22:17

   ╷
22 │   connectivity: ^0.4.9+2
   │                 ^^^^^^^^
   ╵
The constraint `^2.1.0` on flutter_dotenv does not support the latest published version `3.1.0`

pubspec.yaml:20:19

   ╷
20 │   flutter_dotenv: ^2.1.0
   │                   ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs