micons_cli 0.0.10 copy "micons_cli: ^0.0.10" to clipboard
micons_cli: ^0.0.10 copied to clipboard

The oficial CLI for icons.meedu.app

3
likes
90/ 140
pub points
0%
popularity

We analyzed this package 19 hours ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

99 out of 212 API elements (46.7 %) have documentation comments.

Some symbols that are missing documentation: auth_repository_impl, auth_repository_impl.AuthRepositoryImpl, auth_repository_impl.AuthRepositoryImpl.AuthRepositoryImpl, auth_repository_impl.AuthRepositoryImpl.logout, auth_repository_impl.AuthRepositoryImpl.requestCredentials.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:micons_cli/commands/init.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:micons_cli/commands/init.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:micons_cli/commands/init.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Linux`.

Because:

  • package:micons_cli/commands/init.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console2/dart_console2.dart that imports:
  • package:dart_console2/src/console.dart that imports:
  • package:dart_console2/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:micons_cli/commands/init.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console2/dart_console2.dart that imports:
  • package:dart_console2/src/console.dart that imports:
  • package:dart_console2/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/domain/models/http_result.freezed.dart:152:17

    ╷
152 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/domain/models/http_result.freezed.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/domain/models/http_result.freezed.dart:298:17

    ╷
298 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/domain/models/http_result.freezed.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive ^3.3.7 3.4.10 3.4.10
args ^2.4.0 2.4.2 2.4.2
dcli ^3.1.0 3.3.5 3.3.5
freezed_annotation ^2.2.0 2.4.1 2.4.1
http ^1.1.0 1.2.1 1.2.1
json_annotation ^4.8.0 4.8.1 4.8.1
jwt_decode ^0.3.1 0.3.1 0.3.1
meedu ^9.0.0 9.0.3 9.0.3
path ^1.8.3 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
chunked_stream - 1.4.2 1.4.2
circular_buffer - 0.11.0 0.11.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
completer_ex - 4.0.0 4.0.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
csv - 5.1.1 5.1.1
dart_console2 - 3.0.0 3.0.0
dcli_core - 3.3.5 3.3.5
dcli_terminal - 0.2.0 0.2.0
equatable - 2.0.5 2.0.5
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
fsm2 - 3.0.0 3.0.0
functional_data - 1.1.1 1.1.1
glob - 2.1.2 2.1.2
globbing - 1.0.0 1.0.0
http_parser - 4.0.2 4.0.2
ini - 2.1.0 2.1.0
intl - 0.18.1 0.19.0
js - 0.7.1 0.7.1
json2yaml - 3.0.1 3.0.1
lists - 1.0.1 1.0.1
logger - 2.0.2+1 2.0.2+1
logging - 1.2.0 1.2.0
meta - 1.12.0 1.12.0
mime - 1.0.5 1.0.5
pointycastle - 3.7.4 3.7.4
posix - 6.0.1 6.0.1
pub_semver - 2.1.4 2.1.4
pubspec_lock - 3.0.2 3.0.2
pubspec_manager - 1.0.0-alpha.16 1.0.0-alpha.16
scope - 4.1.0 4.1.0
settings_yaml - 8.0.1 8.0.1
simple_logger - 1.9.0+3 1.9.0+3
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stack_trace - 1.11.1 1.11.1
stacktrace_impl - 2.3.0 2.3.0
string_scanner - 1.2.0 1.2.0
strings - 3.0.0 3.0.0
sum_types - 0.3.5 0.3.5
synchronized - 3.1.0+1 3.1.0+1
system_info2 - 4.0.0 4.0.0
term_glyph - 1.2.1 1.2.1
tree_iterator - 3.0.0 3.0.0
typed_data - 1.3.2 1.3.2
unicode - 0.3.1 0.3.1
uuid - 4.3.3 4.3.3
validators2 - 5.0.0 5.0.0
web - 0.5.0 0.5.0
win32 - 4.1.4 5.2.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.4.0-131.0.dev.

Check the analysis log for details.