masamune_agora 2.4.42 copy "masamune_agora: ^2.4.42" to clipboard
masamune_agora: ^2.4.42 copied to clipboard

unlisted

Plug-in for Masamune framework to use Agora.io. Includes support for recording.

0
likes
140/ 140
pub points
40%
popularity

We analyzed this package in the last hour, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

140 out of 140 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Web

These platforms are not supported:

Package does not support platform `Linux`.

Because:

  • package:masamune_agora/masamune_agora.dart that imports:
  • package:masamune_agora/src/others/others.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows, Web.
Package does not support platform `macOS`.

Because:

  • package:masamune_agora/masamune_agora.dart that imports:
  • package:masamune_agora/src/others/others.dart that imports:
  • package:permission_handler/permission_handler.dart that declares support for platforms: Android, iOS, Windows, Web.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
agora_rtc_engine ^6.2.1 6.3.0 6.3.0
flutter flutter 0.0.0 0.0.0
katana ^2.13.2 2.13.2 2.13.2
masamune ^2.11.9 2.12.0 2.12.0
permission_handler ^11.0.0 11.3.1 11.3.1
universal_platform ^1.0.0+1 1.0.0+1 1.0.0+1
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
asn1lib - 1.5.2 1.5.2
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
csv - 5.1.1 6.0.0
encrypt - 5.0.3 5.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_picker - 2.1.0 2.1.0
flutter_rating_bar - 4.0.1 4.0.1
flutter_svg - 2.0.10+1 2.0.10+1
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
intl - 0.19.0 0.19.0
iris_method_channel - 2.0.1 2.1.0
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
katana_auth - 2.8.4 2.8.4
katana_form - 2.12.11 2.12.11
katana_functions - 2.6.4 2.6.4
katana_indicator - 2.2.3 2.2.3
katana_listenables - 2.2.5 2.2.5
katana_listenables_annotation - 2.1.5 2.1.5
katana_localization - 2.3.6 2.3.6
katana_localization_annotation - 2.2.5 2.2.5
katana_logger - 2.2.4 2.2.4
katana_model - 2.26.5 2.26.5
katana_model_local - 2.13.14 2.13.14
katana_prefs - 2.2.5 2.2.5
katana_prefs_annotation - 2.1.5 2.1.5
katana_router - 2.2.10 2.2.10
katana_router_annotation - 2.1.5 2.1.5
katana_scoped - 2.4.0 2.4.0
katana_shorten - 2.1.5 2.1.5
katana_storage - 2.2.4 2.2.4
katana_theme - 2.5.3 2.5.3
katana_theme_annotation - 2.2.3 2.2.3
katana_ui - 2.6.6 2.6.6
masamune_annotation - 2.6.7 2.6.7
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
path_parsing - 1.0.1 1.0.1
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
permission_handler_android - 12.0.5 12.0.5
permission_handler_apple - 9.4.4 9.4.4
permission_handler_html - 0.1.1 0.1.1
permission_handler_platform_interface - 4.2.1 4.2.1
permission_handler_windows - 0.2.1 0.2.1
petitparser - 6.0.2 6.0.2
pin_input_text_field - 4.5.1 4.5.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pointycastle - 3.8.0 3.8.0
recase - 4.1.0 4.1.0
shared_preferences - 2.2.3 2.2.3
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
shimmer - 3.0.0 3.0.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_graphics - 1.1.11+1 1.1.11+1
vector_graphics_codec - 1.1.11+1 1.1.11+1
vector_graphics_compiler - 1.1.11+1 1.1.11+1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

0
likes
140
pub points
40%
popularity

Publisher

verified publishermathru.net

Plug-in for Masamune framework to use Agora.io. Includes support for recording.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

agora_rtc_engine, flutter, katana, masamune, permission_handler, universal_platform

More

Packages that depend on masamune_agora