katana_ui 2.6.3 copy "katana_ui: ^2.6.3" to clipboard
katana_ui: ^2.6.3 copied to clipboard

A package that provides widgets for UI to facilitate design and implementation.

Masamune logo

Katana UI

Follow on Twitter Follow on Threads Maintained with Melos

GitHub Sponsor


[GitHub] | [YouTube] | [Packages] | [Twitter] | [Threads] | [LinkedIn] | [mathru.net]


This package is a collection of additional features around the UI available in the Katana/Masamune framework.

Installation #

Import the following packages

flutter pub add katana_ui

How to use #

Alert and confirmation dialogs can be displayed.

// Alert dialog.
Modal.alert(
  title: "Title",
  text: "Contents text",
  submitText: "OK",
  onSubmit: () {
    // Processing when the OK button is pressed
  },
);

// Confirmation dialog.
Modal.confirm(
  title: "Title",
  text: "Contents text",
  submitText: "Yes",
  cancelText: "No",
  onSubmit: () {
    // Processing when the Yes button is pressed    
  },
  onCancel: () {
    // Processing when the No button is pressed
  }
);

GitHub Sponsors #

Sponsors are always welcome. Thank you for your support!

https://github.com/sponsors/mathrunet

0
likes
140
pub points
16%
popularity

Publisher

verified publishermathru.net

A package that provides widgets for UI to facilitate design and implementation.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, katana, shimmer, universal_platform

More

Packages that depend on katana_ui