knt_ui 2.2.0 copy "knt_ui: ^2.2.0" to clipboard
knt_ui: ^2.2.0 copied to clipboard

A Flutter package contains all handy widgets for Appixi's future projects

0
likes
110/ 140
pub points
33%
popularity

We analyzed this package 34 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/appixi/knt_ui was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: knt_ui,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1444 out of 2623 API elements (55.1 %) have documentation comments.

Some symbols that are missing documentation: assets.gen.AssetGenImage, assets.gen.AssetGenImage.AssetGenImage, assets.gen.AssetGenImage.image, assets.gen.AssetGenImage.keyName, assets.gen.AssetGenImage.path.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:knt_ui/knt_ui.dart that imports:
  • package:knt_ui/src/widget/widgets.dart that imports:
  • package:knt_ui/src/widget/web/knt_web_page.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:knt_ui/knt_ui.dart that imports:
  • package:knt_ui/src/widget/widgets.dart that imports:
  • package:knt_ui/src/widget/web/knt_web_page.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:knt_ui/knt_ui.dart that imports:
  • package:knt_ui/src/widget/widgets.dart that imports:
  • package:knt_ui/src/widget/web/knt_web_page.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:knt_ui/knt_ui.dart that imports:
  • package:knt_ui/src/widget/widgets.dart that imports:
  • package:knt_ui/src/widget/web/knt_web_page.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:knt_ui/knt_ui.dart that imports:
  • package:knt_ui/src/widget/widgets.dart that imports:
  • package:knt_ui/src/widget/knt_issuing_widget.dart that imports:
  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:knt_ui/knt_ui.dart that imports:
  • package:knt_ui/src/widget/widgets.dart that imports:
  • package:knt_ui/src/widget/knt_issuing_widget.dart that imports:
  • package:knt_bloc/knt_bloc.dart that imports:
  • package:knt_bloc/src/ui/paging_widget.dart that imports:
  • package:knt_bloc/src/bloc/blocs.dart that imports:
  • package:connectivity_plus/connectivity_plus.dart that imports:
  • package:connectivity_plus/src/connectivity_plus_linux.dart that imports:
  • package:nm/nm.dart that declares support for platforms: Linux.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'textScaleFactor' is deprecated and shouldn't be used. Use textScaler instead. Use of textScaleFactor was deprecated in preparation for the upcoming nonlinear text scaling support. This feature was deprecated after v3.12.0-2.0.pre.

lib/src/widget/knt_app_wrapper.dart:59:17

   ╷
59 │                 textScaleFactor: DefinedUI.defaultFontScaleFactor,
   │                 ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widget/knt_app_wrapper.dart

OK
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cached_network_image ^3.2.3 3.3.1 3.3.1
device_info_plus ^9.0.2 9.1.2 10.1.0
device_preview ^1.1.0 1.1.0 1.1.0
easy_localization ^3.0.2 3.0.5 3.0.5
flutter flutter 0.0.0 0.0.0
flutter_screenutil ^5.9.0 5.9.0 5.9.0
flutter_spinkit ^5.2.0 5.2.1 5.2.1
flutter_staggered_grid_view 0.4.0 0.4.0 0.7.0
flutter_svg ^2.0.6 2.0.10+1 2.0.10+1
fluttertoast ^8.2.2 8.2.5 8.2.5
focus_detector ^2.0.1 2.0.1 2.0.1
in_app_review ^2.0.6 2.0.9 2.0.9
intl ^0.18.0 0.18.1 0.19.0
knt_bloc ^4.0.1 4.1.1 4.1.1
package_info_plus ^4.0.2 4.2.0 7.0.0
photo_view ^0.14.0 0.14.0 0.15.0
share ^2.0.4 2.0.4 2.0.4
shimmer ^3.0.0 3.0.0 3.0.0
url_launcher ^6.1.11 6.2.6 6.2.6
webview_flutter ^4.2.1 4.7.0 4.7.0
Transitive dependencies
Package Constraint Compatible Latest
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
bloc - 8.1.4 8.1.4
bloc_concurrency - 0.2.5 0.2.5
cached_network_image_platform_interface - 4.0.0 4.0.0
cached_network_image_web - 1.1.1 1.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
connectivity_plus - 4.0.2 6.0.2
connectivity_plus_platform_interface - 1.2.4 2.0.0
crypto - 3.0.3 3.0.3
dbus - 0.7.10 0.7.10
device_frame - 1.1.0 1.1.0
device_info_plus_platform_interface - 7.0.0 7.0.0
dio - 5.4.3+1 5.4.3+1
easy_logger - 0.0.2 0.0.2
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_bloc - 8.1.5 8.1.5
flutter_cache_manager - 3.3.1 3.3.1
flutter_localizations - 0.0.0 0.0.0
flutter_web_plugins - 0.0.0 0.0.0
freezed_annotation - 2.4.1 2.4.1
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
in_app_review_platform_interface - 2.0.5 2.0.5
js - 0.6.7 0.7.1
json_annotation - 4.8.1 4.8.1
logger - 1.4.0 2.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
mime - 1.0.5 1.0.5
nested - 1.0.0 1.0.0
nm - 0.5.0 0.5.0
octo_image - 2.0.0 2.0.0
package_info_plus_platform_interface - 2.0.1 3.0.0
path - 1.9.0 1.9.0
path_parsing - 1.0.1 1.0.1
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 6.0.2 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
rxdart - 0.27.7 0.27.7
scroll_to_index - 3.0.1 3.0.1
shared_preferences - 2.2.3 2.2.3
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
sqflite - 2.3.3 2.3.3
sqflite_common - 2.5.4 2.5.4
stream_transform - 2.1.0 2.1.0
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
url_launcher_android - 6.3.1 6.3.1
url_launcher_ios - 6.2.5 6.2.5
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
uuid - 4.4.0 4.4.0
vector_graphics - 1.1.11+1 1.1.11+1
vector_graphics_codec - 1.1.11+1 1.1.11+1
vector_graphics_compiler - 1.1.11+1 1.1.11+1
vector_math - 2.1.4 2.1.4
visibility_detector - 0.2.2 0.4.0+2
web - 0.5.1 0.5.1
webview_flutter_android - 3.16.0 3.16.0
webview_flutter_platform_interface - 2.10.0 2.10.0
webview_flutter_wkwebview - 3.13.0 3.13.0
win32 - 5.4.0 5.4.0
win32_registry - 1.1.3 1.1.3
xdg_directories - 1.0.4 1.0.4
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^9.0.2` on device_info_plus does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions device_info_plus to update the constraint.

The constraint `0.4.0` on flutter_staggered_grid_view does not support the stable version `0.4.1`.

Try running dart pub upgrade --major-versions flutter_staggered_grid_view to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.