impact 0.0.5
impact: ^0.0.5 copied to clipboard

A new Flutter package.

0
likes
70/ 130
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.
The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 192 out of 1815 API elements (10.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:impact/0_Impact_Global/10_Impact_Google_Login.dart that imports:
  • package:impact/0_Impact_Global/2_Shared_Preference.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 97 issues. Showing the first 2:

lib/0_Impact_Global/10_Impact_Google_Login.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/0_Impact_Global/11_Impact_Get_Device.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^3.1.03.2.03.2.0
cupertino_icons^1.0.21.0.41.0.4
dart_ipify^1.1.01.1.11.1.1
device_info^2.0.22.0.32.0.3
file_picker^3.0.33.0.44.2.7
firebase_core^1.3.01.10.21.10.2
firebase_messaging^10.0.410.0.911.2.0
flag^5.0.0-nullsafety5.0.15.0.1
flutterflutter0.0.00.0.0
flutter_facebook_auth^3.5.03.5.6+33.5.6+3
flutter_spinkit^5.0.05.1.05.1.0
geolocator^7.2.0+17.7.18.0.0
google_sign_in^5.0.45.2.15.2.1
http^0.13.30.13.40.13.4
shared_preferences^2.0.62.0.92.0.9
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
device_info_platform_interface-2.0.12.0.1
enum_to_string-2.0.12.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
firebase_core_platform_interface-4.2.04.2.0
firebase_core_web-1.4.01.4.0
firebase_messaging_platform_interface-3.1.03.1.0
firebase_messaging_web-2.2.12.2.1
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.3.03.3.0
flutter_facebook_auth_platform_interface-2.7.02.7.0
flutter_facebook_auth_web-2.6.0+22.6.0+2
flutter_plugin_android_lifecycle-2.0.52.0.5
flutter_svg-0.22.01.0.0
flutter_web_plugins-0.0.00.0.0
geolocator_android-2.1.03.0.0+4
geolocator_apple-1.2.22.0.0+2
geolocator_platform_interface-2.3.63.0.0+1
geolocator_web-2.0.62.1.0
google_sign_in_platform_interface-2.1.02.1.0
google_sign_in_web-0.10.0+30.10.0+3
http_parser-4.0.04.0.0
js-0.6.30.6.3
matcher-0.12.110.12.11
meta-1.7.01.7.0
octo_image-1.0.11.0.1
path-1.8.01.8.0
path_drawing-0.5.1+11.0.0
path_parsing-0.2.11.0.0
path_provider-2.0.72.0.7
path_provider_android-2.0.92.0.9
path_provider_ios-2.0.72.0.7
path_provider_linux-2.1.22.1.2
path_provider_macos-2.0.32.0.3
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.42.0.4
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.1.03.1.0
plugin_platform_interface-2.0.22.0.2
process-4.2.44.2.4
quiver-3.0.1+13.0.1+1
rxdart-0.27.30.27.3
shared_preferences_android-2.0.92.0.9
shared_preferences_ios-2.0.82.0.8
shared_preferences_linux-2.0.32.0.3
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.22.0.2
shared_preferences_windows-2.0.32.0.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uuid-3.0.53.0.5
vector_math-2.1.02.1.1
win32-2.3.12.3.1
xdg_directories-0.2.00.2.0
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^3.0.3` on file_picker does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions file_picker to update the constraint.

The constraint `^10.0.4` on firebase_messaging does not support the stable version `11.0.0`, that was published 28 days ago.

When firebase_messaging is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions firebase_messaging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.