fastyle_dart 1.5.0 copy "fastyle_dart: ^1.5.0" to clipboard
fastyle_dart: ^1.5.0 copied to clipboard

Set of graphical Widgets.

0
likes
110/ 140
pub points
0%
popularity

We analyzed this package 7 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: ISC.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

683 out of 2046 API elements (33.4 %) have documentation comments.

Some symbols that are missing documentation: action_card.widget, action_card.widget.FastActionCard, action_card.widget.FastActionCard.FastActionCard, action_card.widget.FastActionCard.backgroundColor, action_card.widget.FastActionCard.child.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'useMaterial3' is deprecated and shouldn't be used. Use a ThemeData constructor (.from, .light, or .dark) instead. These constructors all have a useMaterial3 argument, and they set appropriate default values based on its value. See the useMaterial3 API documentation for full details. This feature was deprecated after v3.13.0-0.2.pre.

lib/ui/widgets/buttons/icon_button.dart:55:32

   ╷
55 │       data: themeData.copyWith(useMaterial3: false),
   │                                ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/ui/widgets/buttons/icon_button.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
another_flushbar ^1.12.30 1.12.30 1.12.30
async ^2.11.0 2.11.0 2.11.0
decimal ^2.3.3 2.3.3 2.3.3
diacritic ^0.1.4 0.1.5 0.1.5
flutter flutter 0.0.0 0.0.0
flutter_spinkit ^5.2.0 5.2.1 5.2.1
font_awesome_flutter ^10.5.0 10.7.0 10.7.0
fuzzy ^0.4.0-nullsafety.0 0.4.0-nullsafety.0 0.5.1
go_router ^10.0.0 10.2.0 13.2.4
google_fonts ^4.0.4 4.0.5 6.2.1
intl ^0.18.0 0.18.1 0.19.0
rxdart ^0.27.7 0.27.7 0.27.7
shimmer ^3.0.0 3.0.0 3.0.0
t_helpers >=0.0.21 <2.0.0 0.0.47 0.0.55
tbloc >=0.21.0 <1.0.0 0.21.8+6 0.24.0
tmodel >=0.5.3 <1.0.0 0.5.12+6 0.5.15
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
equatable - 2.0.5 2.0.5
ffi - 2.1.2 2.1.2
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
latinize - 0.1.0-nullsafety.0 0.1.0-nullsafety.0
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
rational - 2.2.2 2.2.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
string_scanner - 1.2.0 1.2.0
subx - 1.14.0 1.14.0
term_glyph - 1.2.1 1.2.1
tsub - 1.12.0 1.12.0
tuple - 2.0.2 2.0.2
typed_data - 1.3.2 1.3.2
uuid - 4.4.0 4.4.0
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.4.0-nullsafety.0` on fuzzy does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions fuzzy to update the constraint.

The constraint `^10.0.0` on go_router does not support the stable version `11.0.0`.

Try running dart pub upgrade --major-versions go_router to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.