bones_ui 1.2.0
bones_ui: ^1.2.0 copied to clipboard

Bones_UI - Simple and easy Web User Interface Framework for Dart

2
likes
50 / 110
pub points
40 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 200 out of 1293 API elements (15.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:bones_ui/bones_ui.dart that imports:
  • package:bones_ui/src/component/svg.dart that imports:
  • package:dom_tools/dom_tools.dart that imports:
  • package:dom_tools/src/perspective_filter.dart that imports:
  • package:dom_tools/src/dom_tools_paint.dart that imports:
  • dart:html
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

ERROR: 'UIComponentGenerator.generate' ('Element Function(DOMGenerator

lib/src/bones_ui_base.dart:773:11

    ╷
773 │   Element generate(
    │           ^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bones_ui_base.dart

ERROR: 'BUIElementGenerator.generate' ('DivElement Function(DOMGenerator

lib/src/component/bui.dart:21:14

   ╷
21 │   DivElement generate(
   │              ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/component/bui.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^2.0.132.0.133.0.0
dom_builder^1.0.241.0.251.0.25
dom_tools^1.3.201.3.201.3.20
dynamic_call^1.0.161.0.171.0.17
enum_to_string^1.0.141.0.141.0.14
expressions^0.1.50.1.50.1.5
html_unescape^1.0.21.0.21.0.2
intl^0.16.10.16.10.17.0
intl_messages^1.1.131.1.131.1.13
json_object_mapper^1.1.31.1.31.1.3
json_render^1.3.81.3.81.3.8
mercury_client^1.1.161.1.181.1.18
service_worker^0.2.40.2.40.2.4
swiss_knife^2.5.242.5.252.5.25
yaml^2.2.12.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
amdjs-1.0.71.0.7
args-1.6.02.0.0
charcode-1.1.31.2.0
chart_engine-1.1.101.1.10
collection-1.14.131.15.0
color_palette_generator-1.0.41.0.4
convert-2.1.13.0.0
crypto-2.1.53.0.0
csslib-0.16.20.17.0
html-0.14.0+40.15.0
js-0.6.20.6.3
markdown-3.0.04.0.0
matcher-0.12.90.12.10
meta-1.2.41.3.0
path-1.7.01.8.0
petitparser-3.1.04.0.2
quiver-2.1.53.0.0
resource_portable-2.1.82.1.8
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^2.0.13` on archive does not support the latest published version `3.0.0`

pubspec.yaml:32:12

   ╷
32 │   archive: ^2.0.13
   │            ^^^^^^^
   ╵
The constraint `^0.16.1` on intl does not support the latest published version `0.17.0`

pubspec.yaml:29:9

   ╷
29 │   intl: ^0.16.1
   │         ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.