ap_common 0.9.1
ap_common: ^0.9.1

Flutter Android iOS web

The school affairs(AP) series shares the engineering kit, rapid development of the school affairs series(AP) app

0
likes
75 / 110
pub points
54 %
popularity

We analyzed this package on Nov 24, 2020, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 88 out of 1478 API elements (6.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: The value of the field 'error' isn't used.

lib/pages/announcement_content_page.dart:17:33

   ╷
17 │ enum _Status { loading, finish, error, empty }
   │                                 ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/pages/announcement_content_page.dart

INFO: The value of the field 'empty' isn't used.

lib/pages/announcement_content_page.dart:17:40

   ╷
17 │ enum _Status { loading, finish, error, empty }
   │                                        ^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/pages/announcement_content_page.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
add_2_calendar^1.4.01.4.01.4.0
auto_size_text^2.1.02.1.02.1.0
barcode^1.17.11.17.11.17.1
barcode_widget^1.5.01.5.01.5.0
cached_network_image^2.3.32.3.32.3.3
cookie_jar>=1.0.0 <2.0.01.0.11.0.1
dio>=3.0.0 <4.0.03.0.103.0.10
dio_cookie_manager>=1.0.0 <2.0.01.0.01.0.0
encrypt>=4.1.0 <5.0.04.1.04.1.0
flutter_cupertino_localizations^1.0.11.0.11.0.1
flutter_keyboard_visibility^3.2.23.3.04.0.1
flutter_linkify^3.1.33.1.34.0.2
flutter_local_notifications^2.0.22.0.23.0.1+5
in_app_review^0.2.10.2.1+11.0.3
intl>=0.16.0 <1.0.00.16.10.16.1
material_design_icons_flutter^4.0.57554.0.57554.0.5755
native_pdf_view^3.8.03.8.03.8.0
package_info^0.4.30.4.3+20.4.3+2
photo_view>=0.10.2 <1.0.00.10.30.10.3
share>=0.6.5+3 <2.0.00.6.5+40.6.5+4
shared_preferences^0.5.12+20.5.12+40.5.12+4
sprintf^5.0.05.0.05.0.0
timezone^0.5.90.5.90.5.9
toast>=0.1.4 <1.0.00.1.50.1.5
url_launcher^5.7.75.7.105.7.10
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.132.0.13
args-1.6.01.6.0
asn1lib-0.8.10.8.1
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
clock-1.0.11.1.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
device_info-0.4.2+101.0.0
device_info_platform_interface-1.0.11.0.1
extended_image-1.3.01.3.0
extended_image_library-0.3.00.3.0
extension-0.1.10.1.1
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_blurhash-0.5.00.5.0
flutter_cache_manager-2.0.02.0.0
flutter_local_notifications_platform_interface-2.0.0+12.0.0+1
http-0.12.20.12.2
http_client_helper-0.2.10.2.1
http_parser-3.1.43.1.4
image-2.1.192.1.19
js-0.6.3-nullsafety.30.6.3-nullsafety.3
linkify-2.1.03.0.0
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
mime-0.9.70.9.7
native_pdf_renderer-2.3.22.3.2
octo_image-0.3.00.3.0
path-1.8.0-nullsafety.31.8.0-nullsafety.3
path_provider-1.6.241.6.24
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+60.0.4+6
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
petitparser-3.1.03.1.0
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
pointycastle-2.0.02.0.0
process-3.0.133.0.13
qr-1.3.01.3.0
rxdart-0.24.10.24.1
shared_preferences_linux-0.0.2+40.0.2+4
shared_preferences_macos-0.0.1+110.0.1+11
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+30.0.1+3
source_span-1.7.01.8.0-nullsafety.4
sqflite-1.3.2+11.3.2+1
sqflite_common-1.0.2+11.0.2+1
string_scanner-1.0.51.1.0-nullsafety.3
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
url_launcher_linux-0.0.1+40.0.1+4
url_launcher_macos-0.0.1+90.0.1+9
url_launcher_platform_interface-1.0.91.0.9
url_launcher_web-0.1.5+10.1.5+1
url_launcher_windows-0.0.1+30.0.1+3
uuid-2.2.22.2.2
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2
xml-4.5.14.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^3.2.2` on flutter_keyboard_visibility does not support the latest published version `4.0.1`

pubspec.yaml:31:32

   ╷
31 │   flutter_keyboard_visibility: ^3.2.2
   │                                ^^^^^^
   ╵
The constraint `^3.1.3` on flutter_linkify does not support the latest published version `4.0.2`

pubspec.yaml:39:20

   ╷
39 │   flutter_linkify: ^3.1.3
   │                    ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs