add_2_calendar 1.3.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 94

add_2_calendar #

A really simple Flutter plugin to add events to each platform's default calendar.

Installation #

In your pubspec.yaml file within your Flutter Project:

dependencies:
  add_2_calendar: ^1.3.0

iOS integration #

In order to make this plugin work on iOS 10+, be sure to add this to your info.plist file:

<key>NSCalendarsUsageDescription</key>
<string>INSERT_REASON_HERE</string>

Use it #

import 'package:add_2_calendar/add_2_calendar.dart';

final Event event = Event(
      title: 'Event title',
      description: 'Event description',
      location: 'Event location',
      startDate: DateTime(/* Some date here */),
      endDate: DateTime(/* Some date here */),
    );
...
Add2Calendar.addEvent2Cal(event);
...

Example #

Please run the app in the example/ folder to start playing!

1.3.0 #

  • Fixed 32bit system conversion on iOS (issue #13)

1.2.2 #

  • Full project refactor
  • Add some comments

1.2.1 #

  • Format code

1.2.0 #

  • Added location support for iOS thanks to @gopchi

1.1.0 #

  • Added allDay boolean
  • Fixed bugs

1.0.3 #

  • Fixed iOS returning always success (issue #5)

1.0.2 #

  • Added necessary entitlements for iOS 10+ integration

1.0.1 #

  • Events are no longer marked as "all day" on Android

1.0.0 #

  • First stable release
  • Added support for iOS

0.0.1 #

  • Initial release (only compatible with Android)

example/README.md

add_2_calendar_example #

Demonstrates how to use the add_2_calendar plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  add_2_calendar: ^1.3.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:add_2_calendar/add_2_calendar.dart';
  
Version Uploaded Documentation Archive
1.3.0 May 29, 2019 Go to the documentation of add_2_calendar 1.3.0 Download add_2_calendar 1.3.0 archive
1.2.2 Feb 25, 2019 Go to the documentation of add_2_calendar 1.2.2 Download add_2_calendar 1.2.2 archive
1.2.1 Feb 8, 2019 Go to the documentation of add_2_calendar 1.2.1 Download add_2_calendar 1.2.1 archive
1.2.0 Feb 8, 2019 Go to the documentation of add_2_calendar 1.2.0 Download add_2_calendar 1.2.0 archive
1.1.0 Jan 31, 2019 Go to the documentation of add_2_calendar 1.1.0 Download add_2_calendar 1.1.0 archive
1.0.3 Jan 31, 2019 Go to the documentation of add_2_calendar 1.0.3 Download add_2_calendar 1.0.3 archive
1.0.2 Oct 31, 2018 Go to the documentation of add_2_calendar 1.0.2 Download add_2_calendar 1.0.2 archive
1.0.1 Oct 31, 2018 Go to the documentation of add_2_calendar 1.0.1 Download add_2_calendar 1.0.1 archive
1.0.0 Oct 30, 2018 Go to the documentation of add_2_calendar 1.0.0 Download add_2_calendar 1.0.0 archive
0.0.1 Oct 30, 2018 Go to the documentation of add_2_calendar 0.0.1 Download add_2_calendar 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
90
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
95
Overall:
Weighted score of the above. [more]
94
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8