alice 0.2.3
alice: ^0.2.3 copied to clipboard

Alice is an HTTP Inspector tool which helps debugging http requests. It catches and stores http requests and responses, which can be viewed via simple UI.

90
likes
120 / 130
pub points
93 %
popularity

We analyzed this package on Jul 31, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 81 out of 276 API elements (29.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:alice/alice.dart that imports:
  • package:alice/core/alice_http_client_adapter.dart that imports:
  • package:alice/core/alice_core.dart that imports:
  • package:flutter_local_notifications/flutter_local_notifications.dart that declares support for platforms: Android, iOS, macOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
better_player^0.0.720.0.720.0.72
chopper^4.0.14.0.14.0.1
collection^1.15.01.15.01.15.0
dio^4.0.04.0.04.0.0
flutterflutter0.0.00.0.0
flutter_local_notifications^6.0.06.1.18.0.0
http^0.13.30.13.30.13.3
open_file^3.2.13.2.13.2.1
package_info^2.0.22.0.22.0.2
path_provider^2.0.22.0.22.0.2
permission_handler^8.1.28.1.4+28.1.4+2
rxdart^0.27.10.27.10.27.1
sensors^2.0.32.0.32.0.3
share^2.0.42.0.42.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.1
characters-1.1.01.1.0
charcode-1.3.11.3.1
csslib-0.17.00.17.0
cupertino_icons-1.0.31.0.3
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_local_notifications_platform_interface-4.0.14.0.1
flutter_web_plugins-0.0.00.0.0
flutter_widget_from_html_core-0.6.1+40.6.1+4
html-0.15.00.15.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
logging-1.0.11.0.1
meta-1.3.01.7.0
mime-1.0.01.0.0
path-1.8.01.8.0
path_provider_linux-2.0.22.0.2
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
permission_handler_platform_interface-3.6.13.6.1
petitparser-4.1.04.2.0
platform-3.0.03.0.0
plugin_platform_interface-2.0.12.0.1
process-4.2.34.2.3
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timezone-0.7.00.7.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
visibility_detector-0.2.00.2.0
wakelock-0.5.20.5.2
wakelock_macos-0.1.0+10.1.0+1
wakelock_platform_interface-0.2.1+10.2.1+1
wakelock_web-0.2.0+10.2.0+1
wakelock_windows-0.1.00.1.0
win32-2.2.52.2.5
xdg_directories-0.2.00.2.0
xml-5.1.25.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.0.0` on flutter_local_notifications does not support the stable version `7.0.0`, that was published 2 days ago.

When flutter_local_notifications is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_local_notifications to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

90
likes
120
pub points
93%
popularity

Alice is an HTTP Inspector tool which helps debugging http requests. It catches and stores http requests and responses, which can be viewed via simple UI.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

better_player, chopper, collection, dio, flutter, flutter_local_notifications, http, open_file, package_info, path_provider, permission_handler, rxdart, sensors, share

More

Packages that depend on alice