alice 0.0.21

  • Readme
  • Changelog
  • Example
  • Installing
  • 90

Alice #

pub package pub package pub package

Alice is an HTTP Inspector tool for Flutter which helps debugging http requests. It catches and stores http requests and responses, which can be viewed via simple UI. It is inspired from Chuck ( ).

Suported Dart http client plugins:

  • Dio
  • HttpClient from dart:io package
  • Http from http/http package
  • Chopper

✔️ Detailed logs for each HTTP calls (HTTP Request, HTTP Response)
✔️ Inspector UI for viewing HTTP calls
✔️ Save HTTP calls to file
✔️ Statistics
✔️ Notification on HTTP call
✔️ Support for top used HTTP clients in Dart
✔️ Error handling
✔️ Shake to open inspector

Install #

  1. Add this to your pubspec.yaml file:
  alice: ^0.0.21
  1. Install it
$ flutter packages get
  1. Import it
import 'package:alice/alice.dart';

Usage #

Alice configuration #

Create Alice instance:

Alice alice = Alice(showNotification: true);

Alice default behaviour is to show notification with http requests. You can disable it in Alice constructor.

Add navigator key to your application:

MaterialApp( navigatorKey: alice.getNavigatorKey(), home: ...)

You need to add this navigator key in order to show inspector UI. You can use also your navigator key in Alice:

Alice alice = Alice(showNotification: true, navigatorKey: yourNavigatorKeyHere);

You can set showInspectorOnShake in Alice constructor to open inspector by shaking your device (default disabled):

Alice alice = Alice(showNotification: true, showInspectorOnShake: true, navigatorKey: yourNavigatorKeyHere);

If you want to use dark mode just add darkTheme flag:

Alice alice = Alice(..., darkTheme: true);

HTTP Client configuration #

If you're using Dio, you just need to add interceptor.

Dio dio = Dio();

If you're using HttpClient from dart:io package:

	.then((request) async {
		var httpResponse = await request.close();
		var responseBody = await httpResponse.transform(utf8.decoder).join();
		alice.onHttpClientResponse(httpResponse, request, body: responseBody);

If you're using http from http/http package:

http.get('').then((response) {

If you're using Chopper. you need to add interceptor:

chopper = ChopperClient(
    interceptors: alice.getChopperInterceptor(),

To show inspector manually:


Saving calls #

Alice supports saving logs to your mobile device storage. In order to make save feature works, you need to add in your Android application manifest:

<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE" />

Example #

See complete example here:

0.0.21 #

  • Added Chopper support
  • Added AndroidX support

0.0.20 #

  • Updated dependencies

0.0.19 #

  • Updated dependencies

0.0.18 #

  • Added share option in call details. Share allows user to share curl of the request. (by: Praveenkumar Ramasamy

0.0.17 #

0.0.16 #

  • Fixed server text overflow

0.0.15 #

  • Updated dependencies

0.0.14 #

  • Fixed Dio API breaking change

0.0.13 #

  • Updated dependencies
  • Notification won't init when showNotification is off

0.0.12 #

  • Updated flutter local notification dependency version
  • Refactor

0.0.11 #

0.0.10 #

  • Added stats feature
  • Added save feature
  • Added secured/not secured connection indicator in call list item
  • Query parameters feature (Dio only)
  • Fix for Uint8List SDK breaking change
  • Updated dependencies
  • Refactored code

0.0.6 #

  • Fixed http/http package requests

0.0.5 #

  • Updated dependencies
  • Navigator key can be provided now from application (instead of using Alice's navigator key)

0.0.4 #

  • Updated Kotlin version

0.0.3 #

  • Removed gif from package

0.0.2 #

  • Bug fixes

0.0.1 #

  • Initial release


alice_example #

Demonstrates how to use the alice plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  alice: ^0.0.21

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:alice/alice.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (flutter_local_notifications, open_file).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
chopper ^3.0.1+1 3.0.1+1
dio ^3.0.7 3.0.8
flutter 0.0.0
flutter_local_notifications ^0.9.0+1 0.9.1+3 1.1.3
http ^0.12.0+2 0.12.0+4
open_file ^2.1.1 2.1.1 3.0.1
package_info ^0.4.0+13 0.4.0+13
path_provider ^1.5.1 1.5.1
permission_handler ^4.0.0 4.2.0+hotfix.2
rxdart ^0.23.1 0.23.1
shake ^0.1.0 0.1.0
share ^0.6.3+5 0.6.3+5
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.11 1.14.12
http_parser 3.1.3
logging 0.11.4
meta 1.1.8
path 1.6.4
pedantic 1.9.0
platform 2.2.1
sensors 0.4.1+7
sky_engine 0.0.99
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8