alex 0.3.0-dev.5

Dart native
Flutter Android iOS

Tools for managing Flutter applications.

2
likes
80 / 110
pub points
3 %
popularity

We analyzed this package on Oct 23, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 55 out of 155 API elements (35.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:alex/alex.dart that imports:
  • package:alex/src/config.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.6.01.6.01.6.0
ini^2.0.12.0.12.0.1
intl^0.16.10.16.10.16.1
intl_translation^0.17.100.17.10+10.17.10+1
list_ext^0.1.00.1.130.1.13
meta^1.2.21.2.31.2.3
path^1.7.01.7.01.7.0
plain_optional^0.1.30.1.30.1.3
pubspec_yaml^2.0.12.0.12.0.1
recase^3.0.03.0.03.0.0
version^1.2.01.2.01.2.0
xml^4.4.14.5.14.5.1
yaml^2.2.12.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.011.0.0
analyzer-0.39.170.40.4
async-2.4.22.4.2
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
dart_style-1.3.61.3.8
functional_data-0.3.00.3.0
glob-1.2.01.2.0
html-0.14.0+40.14.0+4
js-0.6.20.6.2
json2yaml-1.0.11.0.1
matcher-0.12.90.12.9
node_interop-1.1.11.1.1
node_io-1.1.11.1.1
package_config-1.9.31.9.3
petitparser-3.1.03.1.0
pub_semver-1.4.41.4.4
quiver-2.1.32.1.3
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
sum_types-0.2.1+20.2.1+2
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs