version_migration 2.0.5 icon indicating copy to clipboard operation
version_migration: ^2.0.5 copied to clipboard

Manages functions of code that need to run once on version updates in Flutter apps.

11
likes
130/ 140
pub points
73%
popularity

We analyzed this package 34 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 12 API elements (41.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
package_info_plus^1.4.3+11.4.3+13.0.2
platform^3.1.03.1.03.1.0
shared_preferences^2.0.152.0.152.0.15
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
collection-1.16.01.17.0
ffi-2.0.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
http-0.13.50.13.5
http_parser-4.0.24.0.2
js-0.6.40.6.5
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
package_info_plus_linux-1.0.52.0.0
package_info_plus_macos-1.3.02.0.0
package_info_plus_platform_interface-1.0.22.0.1
package_info_plus_web-1.0.62.0.0
package_info_plus_windows-2.1.03.0.0
path-1.8.21.8.2
path_provider_linux-2.1.72.1.7
path_provider_platform_interface-2.0.52.0.5
path_provider_windows-2.1.32.1.3
plugin_platform_interface-2.1.32.1.3
process-4.2.44.2.4
shared_preferences_android-2.0.142.0.14
shared_preferences_ios-2.1.12.1.1
shared_preferences_linux-2.1.12.1.1
shared_preferences_macos-2.0.42.0.4
shared_preferences_platform_interface-2.1.02.1.0
shared_preferences_web-2.0.42.0.4
shared_preferences_windows-2.1.12.1.1
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4
win32-3.1.23.1.2
xdg_directories-0.2.0+20.2.0+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^1.4.3+1 on package_info_plus does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions package_info_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

11
likes
130
pub points
73%
popularity

Publisher

unverified uploader

Manages functions of code that need to run once on version updates in Flutter apps.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

flutter, package_info_plus, platform, shared_preferences

More

Packages that depend on version_migration