universe 1.1.1-nullsafety
universe: ^1.1.1-nullsafety copied to clipboard

The easy & flexible way to use interactive maps in Flutter. Inspired by Leaflet.js.

42
likes
120/ 130
pub points
74%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 520 out of 1558 API elements (33.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:universe/universe.dart that declares support for platforms: Android, iOS.
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^3.1.03.1.03.1.0
curved_animation_controller^1.1.0+11.1.0+11.1.0+1
extended_image^4.2.14.2.14.2.1
flutterflutter0.0.00.0.0
flutter_image^4.1.04.1.04.1.0
flutter_svg^0.22.00.22.00.22.0
geocode^1.0.11.0.11.0.1
html_unescape^2.0.02.0.02.0.0
intl^0.17.00.17.00.17.0
location^4.3.04.3.04.3.0
logging^1.0.11.0.21.0.2
proj4dart^2.0.02.0.02.0.0
provider^6.0.06.0.06.0.0
tuple^2.0.02.0.02.0.0
vector_math^2.1.02.1.02.1.1
video_player^2.1.152.2.42.2.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.2
boolean_selector-2.1.02.1.0
cached_network_image_platform_interface-1.0.01.0.0
cached_network_image_web-1.0.11.0.1
characters-1.1.01.2.0
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
crypto-3.0.13.0.1
extended_image_library-3.1.03.1.0
fake_async-1.2.01.2.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_blurhash-0.6.00.6.0
flutter_cache_manager-3.1.23.1.2
flutter_web_plugins-0.0.00.0.0
http-0.13.30.13.3
http_client_helper-2.0.22.0.2
http_parser-4.0.04.0.0
js-0.6.30.6.3
lists-1.0.11.0.1
location_platform_interface-2.3.02.3.0
location_web-3.1.13.1.1
matcher-0.12.100.12.11
meta-1.7.01.7.0
mgrs_dart-2.0.02.0.0
nested-1.0.01.0.0
octo_image-1.0.0+11.0.0+1
path-1.8.01.8.0
path_drawing-0.5.10.5.1
path_parsing-0.2.10.2.1
path_provider-2.0.52.0.5
path_provider_linux-2.1.02.1.0
path_provider_macos-2.0.22.0.2
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.32.0.3
pedantic-1.11.11.11.1
petitparser-4.3.04.3.0
platform-3.0.23.0.2
plugin_platform_interface-2.0.12.0.1
process-4.2.34.2.3
quiver-3.0.13.0.1
rxdart-0.27.20.27.2
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-2.0.0+42.0.0+4
sqflite_common-2.0.1+12.0.1+1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
test_api-0.4.20.4.3
typed_data-1.3.01.3.0
unicode-0.3.10.3.1
uuid-3.0.43.0.4
video_player_platform_interface-4.2.04.2.0
video_player_web-2.0.42.0.4
win32-2.2.92.2.9
wkt_parser-2.0.02.0.0
xdg_directories-0.2.00.2.0
xml-5.3.05.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.