spec_cli 0.1.2+2 icon indicating copy to clipboard operation
spec_cli: ^0.1.2+2 copied to clipboard

CLI for Spec - a streamlined testing framework for Dart & Flutter.

5
likes
110/ 140
pub points
18%
popularity

We analyzed this package 20 hours ago, and awarded it 110 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Linux
  • ✓ MacOS
  • ✓ Windows

These platforms are not supported:

Android

Cannot assign Android automatically to a binary only package.

iOS

Cannot assign iOS automatically to a binary only package.

Web

Cannot assign Web automatically to a binary only package.

icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'packagesPath' is deprecated and shouldn't be used. Use packagePath.

lib/src/third-party/format_coverage.dart:15:5

   ╷
15 │     packagesPath: packagesPath,
   │     ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/third-party/format_coverage.dart

INFO: 'Resolver.Resolver' is deprecated and shouldn't be used. Use Resolver.create.

lib/src/third-party/format_coverage.dart:18:20

   ╷
18 │   final resolver = Resolver(packagesPath: packagesPath);
   │                    ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/third-party/format_coverage.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansi_styles^0.3.2+10.3.2+10.3.2+1
args^2.1.12.3.12.3.1
cli_util^0.3.00.3.50.3.5
collection^1.15.01.16.01.16.0
coverage^1.1.01.6.11.6.1
dart_test_adapter^0.2.00.2.00.2.0
duration^3.0.83.0.123.0.12
freezed_annotation^1.1.01.1.02.1.0
melos^1.1.21.5.22.7.1
meta^1.7.01.8.01.8.0
path^1.8.01.8.21.8.2
pubspec^2.0.12.3.02.3.0
riverpod^2.0.0-dev.32.0.0-dev.92.0.0-dev.9
test^1.17.81.21.61.21.6
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-49.0.049.0.0
analyzer-5.1.05.1.0
async-2.9.02.9.0
boolean_selector-2.1.02.1.0
charcode-1.3.11.3.1
conventional_commit-0.4.3+10.5.0
convert-3.0.23.0.2
crypto-3.0.23.0.2
file-6.1.46.1.4
frontend_server_client-3.0.03.0.0
glob-2.1.02.1.0
graphs-2.1.02.1.0
http-0.13.50.13.5
http_multi_server-3.2.13.2.1
http_parser-4.0.14.0.1
io-1.0.31.0.3
js-0.6.40.6.4
json_annotation-4.7.04.7.0
logging-1.0.21.0.2
matcher-0.12.120.12.12
mime-1.0.21.0.2
mustache_template-2.0.02.0.0
node_preamble-2.0.12.0.1
package_config-2.1.02.1.0
platform-3.1.03.1.0
pool-1.5.11.5.1
pub_semver-2.1.12.1.1
quiver-3.1.03.1.0
shelf-1.4.01.4.0
shelf_packages_handler-3.0.13.0.1
shelf_static-1.1.11.1.1
shelf_web_socket-1.0.21.0.2
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
state_notifier-0.7.2+10.7.2+1
stream_channel-2.1.12.1.1
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
test_api-0.4.140.4.14
test_core-0.4.180.4.18
typed_data-1.3.11.3.1
uri-1.0.01.0.0
vm_service-9.4.09.4.0
watcher-1.0.11.0.1
web_socket_channel-2.2.02.2.0
webkit_inspection_protocol-1.2.01.2.0
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.0` on freezed_annotation does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions freezed_annotation to update the constraint.

The constraint `^1.1.2` on melos does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions melos to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.17, Dart 2.18.0.

5
likes
110
pub points
18%
popularity

Publisher

verified publisher iconinvertase.io

CLI for Spec - a streamlined testing framework for Dart & Flutter.

Homepage

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

ansi_styles, args, cli_util, collection, coverage, dart_test_adapter, duration, freezed_annotation, melos, meta, path, pubspec, riverpod, test

More

Packages that depend on spec_cli