pix_bb 1.0.4 copy "pix_bb: ^1.0.4" to clipboard
pix_bb: ^1.0.4 copied to clipboard

Easy-to-use interface for integrating with Banco do Brasil's Pix API.

3
likes
120/ 140
pub points
9%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

63 out of 67 API elements (94.0 %) have documentation comments.

Some symbols that are missing documentation: pix_bb, pix_bb.Ambiente, pix_bb.Ambiente.Ambiente, pix_bb.Parametros.paginacao.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'DioError' is deprecated and shouldn't be used. Use DioException instead. This will be removed in 6.0.0.

lib/src/services/dio_client.dart:33:10

   ╷
33 │     } on DioError catch (e) {
   │          ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/services/dio_client.dart

INFO: 'DioError' is deprecated and shouldn't be used. Use DioException instead. This will be removed in 6.0.0.

lib/src/services/dio_client.dart:65:10

   ╷
65 │     } on DioError catch (e) {
   │          ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/services/dio_client.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio >=5.0.1 <6.0.0 5.4.3+1 5.4.3+1
flutter flutter 0.0.0 0.0.0
intl >=0.17.0 <1.0.0 0.19.0 0.19.0
mocktail ^0.3.0 0.3.0 1.0.3
result_dart >=1.0.5 <2.0.0 1.1.1 1.1.1
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 68.0.0
analyzer - 6.4.1 6.5.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
coverage - 1.8.0 1.8.0
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
frontend_server_client - 4.0.0 4.0.0
glob - 2.1.2 2.1.2
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
js - 0.7.1 0.7.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
shelf - 1.4.1 1.4.1
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
sky_engine - 0.0.99 0.0.99
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test - 1.25.2 1.25.5
test_api - 0.7.0 0.7.1
test_core - 0.6.0 0.6.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.2 14.2.2
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
webkit_inspection_protocol - 1.2.1 1.2.1
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.0` on mocktail does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions mocktail to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

3
likes
120
pub points
9%
popularity

Publisher

verified publisheracxtech.com.br

Easy-to-use interface for integrating with Banco do Brasil's Pix API.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio, flutter, intl, mocktail, result_dart

More

Packages that depend on pix_bb