pal 2.0.0+3
pal: ^2.0.0+3 copied to clipboard

The no code Flutter onboarding editor

35
likes
75 / 130
pub points
42 %
popularity

We analyzed this package on May 10, 2021, and awarded it 75 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Documentation URL doesn't exist.

At the time of the analysis https://doc.pal-plugin.tech was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:135:67

    ╷
135 │ | appToken | <code>String</code> | the app token created from the <a href="http://demo.pal-plugin.tech"><strong>admin</strong></a> | ✅ | |</p>
    │                                                                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 20 out of 66 API elements (30.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:pal/pal.dart that imports:
  • package:pal/src/pal.dart that imports:
  • package:pal/src/pal_database_initializer.dart that imports:
  • package:hive_flutter/hive_flutter.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 180 issues. Showing the first 2:

INFO: The operand can't be null, so the condition is always true.

lib/generated/i18n.dart:58:14

   ╷
58 │     if (lang != null) {
   │              ^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/generated/i18n.dart

INFO: The operand can't be null, so the condition is always true.

lib/generated/i18n.dart:100:16

    ╷
100 │     if (locale != null) {
    │                ^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/generated/i18n.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
dotted_border^2.0.02.0.02.0.0
flutterflutter0.0.00.0.0
flutter_colorpicker^0.4.00.4.00.4.0
google_fonts^2.0.02.0.02.0.0
hive^2.0.42.0.42.0.4
hive_flutter^1.0.01.0.01.0.0
http^0.13.20.13.30.13.3
http_parser^4.0.04.0.04.0.0
mvvm_builder^3.0.0-null.safety3.0.0-null.safety3.0.0-null.safety
package_info_plus^1.0.11.0.11.0.1
path_provider^2.0.12.0.12.0.1
rxdart^0.26.00.26.00.27.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.6.12.6.1
characters-1.1.01.1.0
charcode-1.2.01.2.0
crypto-3.0.13.0.1
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.3.0
package_info_plus_linux-1.0.11.0.1
package_info_plus_macos-1.1.11.1.1
package_info_plus_platform_interface-1.0.11.0.1
package_info_plus_web-1.0.11.0.1
package_info_plus_windows-1.0.11.0.1
path-1.8.01.8.0
path_drawing-0.5.10.5.1
path_parsing-0.2.10.2.1
path_provider_linux-2.0.02.0.0
path_provider_macos-2.0.02.0.0
path_provider_platform_interface-2.0.12.0.1
path_provider_windows-2.0.12.0.1
pedantic-1.11.01.11.0
platform-3.0.03.0.0
plugin_platform_interface-2.0.02.0.0
process-4.2.14.2.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.26.0` on rxdart does not support the stable version `0.27.0`, that was published 3 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Null safety support has one or more issues.

Tag detection failed.

Broken import dart:indexed_db

For more information

Try running dart pub outdated --mode=null-safety. Be sure to read the migration guide.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.