meedu_cli 0.0.9 copy "meedu_cli: ^0.0.9" to clipboard
meedu_cli: ^0.0.9 copied to clipboard

A CLI for flutter_meedu

8
likes
110/ 140
pub points
0%
popularity

We analyzed this package 17 hours ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

14 out of 17 API elements (82.4 %) have documentation comments.

Some symbols that are missing documentation: meedu_cli, meedu_cli.Commands, meedu_cli.Commands.Commands.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:meedu_cli/meedu_cli.dart that imports:
  • package:meedu_cli/src/commands/page/page.dart that imports:
  • package:meedu_cli/src/commands/page/state_notifier_template.dart that imports:
  • package:meedu_cli/src/utils/pubspec.dart that imports:
  • package:meedu_cli/src/utils/base_path.dart that imports:
  • package:meedu_cli/src/commands/initialize/initialize.dart that imports:
  • package:meedu_cli/src/commands/initialize/create_clean_structure.dart that imports:
  • package:meedu_cli/src/commands/initialize/generate_test_file.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.3.0 2.4.2 2.4.2
cli_menu ^0.3.0-nullsafety.0 0.3.0-nullsafety.0 0.4.0+1
codemod ^1.0.1 1.2.0 1.2.0
glob ^2.0.1 2.1.2 2.1.2
http ^0.13.3 0.13.6 1.2.1
path ^1.8.0 1.9.0 1.9.0
process_run ^0.12.2+1 0.12.5+3 0.14.2
pub_semver ^2.1.0 2.1.4 2.1.4
pubspec ^2.0.1 2.3.0 2.3.0
pubspec_parse ^1.1.0 1.2.3 1.2.3
yaml ^3.1.0 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 67.0.0
analyzer - 6.4.1 6.4.1
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
charcode - 1.3.1 1.3.1
checked_yaml - 2.0.3 2.0.3
cli_util - 0.3.5 0.4.1
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
coverage - 1.7.2 1.7.2
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
frontend_server_client - 3.2.0 3.2.0
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
js - 0.7.1 0.7.1
json_annotation - 4.8.1 4.8.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.12.0 1.12.0
mime - 1.0.5 1.0.5
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
pool - 1.5.1 1.5.1
quiver - 3.2.1 3.2.1
shelf - 1.4.1 1.4.1
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 1.0.4
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
test - 1.25.2 1.25.2
test_api - 0.7.0 0.7.0
test_core - 0.6.0 0.6.0
test_descriptor - 2.0.1 2.0.1
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
vm_service - 14.0.0 14.0.0
watcher - 1.1.0 1.1.0
web - 0.5.0 0.5.0
web_socket_channel - 2.4.4 2.4.4
webkit_inspection_protocol - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.3.0-nullsafety.0` on cli_menu does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions cli_menu to update the constraint.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.1, Dart 3.4.0-131.0.dev.

Check the analysis log for details.