me 1.0.2 icon indicating copy to clipboard operation
me: ^1.0.2 copied to clipboard

Official CLI for ME framework to build Flutter and Server in my day a day.

1
likes
120/ 140
pub points
17%
popularity

We analyzed this package 25 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 22 out of 120 API elements (18.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:me/me.dart that imports:
  • package:me/commands/commands.dart that imports:
  • package:me/commands/provider_command.dart that imports:
  • package:me/functions/binding/controller.dart that imports:
  • package:me/utils/utils.dart that imports:
  • package:me/utils/menu.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:me/me.dart that imports:
  • package:me/commands/commands.dart that imports:
  • package:me/commands/provider_command.dart that imports:
  • package:me/functions/binding/controller.dart that imports:
  • package:me/utils/utils.dart that imports:
  • package:me/utils/menu.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:me/me.dart that imports:
  • package:me/commands/commands.dart that imports:
  • package:me/commands/provider_command.dart that imports:
  • package:me/functions/binding/controller.dart that imports:
  • package:me/utils/utils.dart that imports:
  • package:me/utils/menu.dart that imports:
  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Windows

Because:

  • package:me/me.dart that imports:
  • package:me/commands/commands.dart that imports:
  • package:me/commands/provider_command.dart that imports:
  • package:me/functions/binding/controller.dart that imports:
  • package:me/utils/utils.dart that imports:
  • package:me/utils/menu.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • dart:cli
Package does not support platform `Linux`.

Because:

  • package:me/me.dart that imports:
  • package:me/commands/commands.dart that imports:
  • package:me/commands/provider_command.dart that imports:
  • package:me/functions/binding/controller.dart that imports:
  • package:me/utils/utils.dart that imports:
  • package:me/utils/menu.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console2/dart_console2.dart that imports:
  • package:dart_console2/src/console.dart that imports:
  • package:dart_console2/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:me/me.dart that imports:
  • package:me/commands/commands.dart that imports:
  • package:me/commands/provider_command.dart that imports:
  • package:me/functions/binding/controller.dart that imports:
  • package:me/utils/utils.dart that imports:
  • package:me/utils/menu.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console2/dart_console2.dart that imports:
  • package:dart_console2/src/console.dart that imports:
  • package:dart_console2/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^2.0.12.0.12.0.1
bosun^0.2.20.2.20.2.2
dart_style^2.2.32.2.42.2.4
dcli^1.32.11.34.01.34.0
path^1.8.21.8.21.8.2
process_run^0.12.3+20.12.3+20.12.3+2
pubspec^2.3.02.3.02.3.0
recase^4.0.04.1.04.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-49.0.049.0.0
analyzer-5.1.05.1.0
archive-3.3.13.3.1
args-2.3.12.3.1
async-2.9.02.9.0
basic_utils-3.9.45.3.0
charcode-1.3.11.3.1
chunked_stream-1.4.11.4.1
circular_buffer-0.11.00.11.0
clock-1.1.11.1.1
collection-1.16.01.16.0
convert-3.0.23.0.2
crypto-3.0.23.0.2
csv-5.0.15.0.1
dart_console2-2.0.02.0.0
dcli_core-1.34.01.34.0
equatable-2.0.52.0.5
ffi-2.0.12.0.1
file-6.1.46.1.4
file_utils-1.0.11.0.1
glob-2.1.02.1.0
globbing-1.0.01.0.0
http-0.13.50.13.5
http_parser-4.0.14.0.1
ini-2.1.02.1.0
intl-0.17.00.17.0
js-0.6.40.6.4
json_annotation-4.7.04.7.0
logging-1.0.21.0.2
matcher-0.12.120.12.12
meta-1.8.01.8.0
mime-1.0.21.0.2
package_config-2.1.02.1.0
pointycastle-3.6.23.6.2
posix-4.0.04.0.0
pub_semver-2.1.12.1.1
pubspec2-2.4.12.4.1
quiver-3.1.03.1.0
random_string-2.3.12.3.1
scope-2.2.12.2.1
settings_yaml-3.5.04.0.0
source_span-1.9.11.9.1
stack_trace-1.10.01.10.0
stacktrace_impl-2.3.02.3.0
string_scanner-1.1.11.1.1
synchronized-3.0.0+33.0.0+3
system_info2-2.0.42.0.4
term_glyph-1.2.11.2.1
tree_iterator-2.0.02.0.0
typed_data-1.3.11.3.1
uri-1.0.01.0.0
uuid-3.0.63.0.6
validators2-3.0.03.0.0
vin_decoder-0.2.1-nullsafety0.2.1-nullsafety
watcher-1.0.11.0.1
win32-2.7.03.0.0
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.17, Dart 2.18.0.

1
likes
120
pub points
17%
popularity

Publisher

unverified uploader

Official CLI for ME framework to build Flutter and Server in my day a day.

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

ansicolor, bosun, dart_style, dcli, path, process_run, pubspec, recase

More

Packages that depend on me