insta_assets_picker 2.3.1 copy "insta_assets_picker: ^2.3.1" to clipboard
insta_assets_picker: ^2.3.1 copied to clipboard

An image picker similar with Instagram, supports multi picking, crop and aspect ratio.

111
likes
160/ 160
pub points
92%
popularity

We analyzed this package 33 hours ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

282 out of 485 API elements (58.1 %) have documentation comments.

Some symbols that are missing documentation: insta_assets_picker, insta_assets_picker.ArabicAssetPickerTextDelegate.accessAllTip, insta_assets_picker.ArabicAssetPickerTextDelegate.accessiblePathName, insta_assets_picker.ArabicAssetPickerTextDelegate.changeAccessibleLimitedAssets, insta_assets_picker.ArabicAssetPickerTextDelegate.goToSystemSettings.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:insta_assets_picker/insta_assets_picker.dart that imports:
  • package:wechat_assets_picker/src/delegates/asset_picker_text_delegate.dart that imports:
  • package:photo_manager/photo_manager.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `Linux`.

Because:

  • package:insta_assets_picker/insta_assets_picker.dart that imports:
  • package:wechat_assets_picker/src/delegates/asset_picker_text_delegate.dart that imports:
  • package:photo_manager/photo_manager.dart that declares support for platforms: Android, iOS, macOS.
Package does not support platform `macOS`.

Because:

  • package:insta_assets_picker/insta_assets_picker.dart that imports:
  • package:insta_assets_picker/src/insta_assets_crop_controller.dart that imports:
  • package:insta_assets_crop/insta_assets_crop.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:insta_assets_picker/insta_assets_picker.dart that imports:
  • package:wechat_assets_picker/src/delegates/asset_picker_text_delegate.dart that imports:
  • package:photo_manager/photo_manager.dart that declares support for platforms: Android, iOS, macOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
extended_image ^8.2.0 8.2.1 8.2.1
flutter flutter 0.0.0 0.0.0
fraction ^5.0.2 5.0.2 5.0.2
insta_assets_crop ^0.0.3 0.0.3 0.0.3
provider ^6.0.5 6.1.2 6.1.2
wechat_assets_picker ^9.1.0 9.1.0 9.1.0
wechat_picker_library ^1.0.0 1.0.0 1.0.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
extended_image_library - 4.0.4 4.0.4
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
html - 0.15.4 0.15.4
http - 1.2.2 1.2.2
http_client_helper - 3.0.0 3.0.0
http_parser - 4.0.2 4.1.0
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.7 2.2.7
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.3.0 2.3.0
photo_manager - 3.2.1 3.2.1
photo_manager_image_provider - 2.1.1 2.1.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
video_player - 2.9.1 2.9.1
video_player_android - 2.5.2 2.5.2
video_player_avfoundation - 2.6.1 2.6.1
video_player_platform_interface - 6.2.2 6.2.2
video_player_web - 2.3.1 2.3.1
web - 0.5.1 1.0.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.