homeconnect_flutter 0.1.0 copy "homeconnect_flutter: ^0.1.0" to clipboard
homeconnect_flutter: ^0.1.0 copied to clipboard

Flutter utility classes, meant to be used with the home connect SDK

0
likes
110/ 140
pub points
48%
popularity

We analyzed this package 7 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

3 out of 15 API elements (20.0 %) have documentation comments.

Some symbols that are missing documentation: homeconnect_flutter, homeconnect_flutter.HomeConnectOauth, homeconnect_flutter.HomeConnectOauth.HomeConnectOauth, homeconnect_flutter.HomeConnectOauth.authorize, homeconnect_flutter.HomeConnectOauth.codeVerifier.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:homeconnect_flutter/homeconnect_flutter.dart that imports:
  • package:homeconnect_flutter/src/authentication.dart that imports:
  • package:homeconnect_flutter/src/components/webview_login.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:homeconnect_flutter/homeconnect_flutter.dart that imports:
  • package:homeconnect_flutter/src/authentication.dart that imports:
  • package:homeconnect_flutter/src/components/webview_login.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:homeconnect_flutter/homeconnect_flutter.dart that imports:
  • package:homeconnect_flutter/src/authentication.dart that imports:
  • package:homeconnect_flutter/src/components/webview_login.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:homeconnect_flutter/homeconnect_flutter.dart that imports:
  • package:homeconnect_flutter/src/authentication.dart that imports:
  • package:homeconnect_flutter/src/components/webview_login.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/src/authentication.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/storage.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
eventsource ^0.4.0 0.4.0 0.4.0
flutter flutter 0.0.0 0.0.0
homeconnect ^0.1.0 0.1.0 0.1.0
http ^0.13.5 0.13.6 1.2.1
json_annotation ^4.8.0 4.9.0 4.9.0
oauth2 ^2.0.1 2.0.2 2.0.2
shared_preferences ^2.0.18 2.2.3 2.2.3
webview_flutter ^4.0.5 4.7.0 4.7.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 67.0.0 68.0.0
analyzer - 6.4.1 6.5.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
build - 2.4.1 2.4.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
characters - 1.3.0 1.3.0
code_builder - 4.10.0 4.10.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
coverage - 1.8.0 1.8.0
crypto - 3.0.3 3.0.3
dart_style - 2.3.6 2.3.6
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
flutter_web_plugins - 0.0.0 0.0.0
frontend_server_client - 4.0.0 4.0.0
glob - 2.1.2 2.1.2
http_multi_server - 3.2.1 3.2.1
http_parser - 4.0.2 4.0.2
io - 1.0.4 1.0.4
js - 0.7.1 0.7.1
logging - 1.2.0 1.2.0
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
mime - 1.0.5 1.0.5
mockito - 5.4.4 5.4.4
node_preamble - 2.0.2 2.0.2
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
pool - 1.5.1 1.5.1
pub_semver - 2.1.4 2.1.4
shared_preferences_android - 2.2.2 2.2.2
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
shelf - 1.4.1 1.4.1
shelf_packages_handler - 3.0.2 3.0.2
shelf_static - 1.1.2 1.1.2
shelf_web_socket - 1.0.4 2.0.0
sky_engine - 0.0.99 0.0.99
source_gen - 1.5.0 1.5.0
source_map_stack_trace - 2.1.1 2.1.1
source_maps - 0.10.12 0.10.12
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
sync - 0.3.0 0.3.0
term_glyph - 1.2.1 1.2.1
test - 1.25.2 1.25.5
test_api - 0.7.0 0.7.1
test_core - 0.6.0 0.6.2
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4
vm_service - 14.2.2 14.2.2
watcher - 1.1.0 1.1.0
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0
webkit_inspection_protocol - 1.2.1 1.2.1
webview_flutter_android - 3.16.2 3.16.2
webview_flutter_platform_interface - 2.10.0 2.10.0
webview_flutter_wkwebview - 3.13.1 3.13.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.