handcash_connect_sdk 0.1.3-dev
handcash_connect_sdk: ^0.1.3-dev copied to clipboard

A Flutter plugin to integrate nanopayments into Apps and Games with HandCash.

3
likes
110/ 130
pub points
22%
popularity

We analyzed this package on Sep 24, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 213 API elements (4.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:handcash_connect_sdk/handcash_connect_sdk.dart that imports:
  • package:handcash_connect_sdk/src/link/handcash_auth_token_listener.dart that imports:
  • package:handcash_connect_sdk/src/link/link_listener.dart that imports:
  • package:uni_links/uni_links.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/models/cloud_api_exception.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/models/exchange_rate.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
asn1lib^1.0.01.0.21.0.2
chopper^4.0.04.0.14.0.1
convert^3.0.03.0.13.0.1
date_time_format^2.0.12.0.12.0.1
flutterflutter0.0.00.0.0
freezed^0.14.20.14.50.14.5
freezed_annotation^0.14.20.14.30.14.3
http^0.13.30.13.30.13.3
json_annotation^4.0.14.1.04.1.0
pointycastle^3.0.13.3.43.3.4
rxdart^0.27.00.27.20.27.2
tuple^2.0.02.0.02.0.0
uni_links^0.5.10.5.10.5.1
url_launcher^6.0.46.0.126.0.12
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-26.0.026.0.0
analyzer-2.3.02.3.0
args-2.3.02.3.0
async-2.8.22.8.2
build-2.1.02.1.0
build_config-1.0.01.0.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
checked_yaml-2.0.12.0.1
cli_util-0.3.30.3.3
collection-1.15.01.15.0
crypto-3.0.13.0.1
dart_style-2.2.02.2.0
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
glob-2.0.12.0.1
http_parser-4.0.04.0.0
js-0.6.30.6.3
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
package_config-2.0.22.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
plugin_platform_interface-2.0.12.0.1
pub_semver-2.1.02.1.0
pubspec_parse-1.1.01.1.0
quiver-3.0.13.0.1
sky_engine-0.0.990.0.99
source_gen-1.1.01.1.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uni_links_platform_interface-1.0.01.0.0
uni_links_web-0.1.00.1.0
url_launcher_linux-2.0.22.0.2
url_launcher_macos-2.0.22.0.2
url_launcher_platform_interface-2.0.42.0.4
url_launcher_web-2.0.42.0.4
url_launcher_windows-2.0.22.0.2
vector_math-2.1.02.1.1
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.