flutter_matrix_html 0.2.0
flutter_matrix_html: ^0.2.0 copied to clipboard

Flutter Android iOS macOS

A Flutter widget for rendering static matrix html tags as Flutter widgets. (Will render over 70 different html tags!)

0
likes
80 / 110
pub points
86 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 179 API elements (6.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:flutter_matrix_html/code_block.dart that imports:
  • package:isolate/isolate.dart that imports:
  • package:isolate/registry.dart that imports:
  • package:isolate/ports.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/html_parser.dart:122:35

    ╷
122 │     List<Widget> widgetList = new List<Widget>();
    │                                   ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/html_parser.dart

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/html_parser.dart:638:35

    ╷
638 │           List<Widget> children = List<Widget>();
    │                                   ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/html_parser.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_imageany2.5.02.5.0
crypto^2.1.52.1.53.0.0
flutterflutter0.0.00.0.0
flutter_highlight^0.6.00.6.00.6.0
flutter_math^0.2.0+20.2.10.2.1
highlight^0.6.00.6.00.6.0
html^0.14.00.14.0+40.15.0
isolate^2.0.32.0.32.0.3
matrix_link_textany0.3.20.3.2
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.0.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
csslib-0.16.20.17.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_blurhash-0.5.00.5.0
flutter_cache_manager-2.1.12.1.1
flutter_svg-0.19.30.19.3
flutter_web_plugins-0.0.00.0.0
http-0.12.20.13.0
http_parser-3.1.44.0.0
image-2.1.193.0.1
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.3.0
nested-1.0.01.0.0
octo_image-0.3.00.3.0
path-1.8.01.8.0
path_drawing-0.4.1+10.4.1+1
path_parsing-0.1.40.1.4
path_provider-1.6.272.0.1
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
pedantic-1.11.01.11.0
petitparser-3.1.04.0.2
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.1.04.1.0
provider-4.3.35.0.0
quiver-2.1.53.0.0
rxdart-0.25.00.26.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite-1.3.2+42.0.0+2
sqflite_common-1.0.3+12.0.0+1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
tuple-1.0.31.0.3
typed_data-1.3.01.3.0
url_launcher-5.7.106.0.2
url_launcher_linux-0.0.1+42.0.0
url_launcher_macos-0.0.1+92.0.0
url_launcher_platform_interface-1.0.92.0.2
url_launcher_web-0.1.5+32.0.0
url_launcher_windows-0.0.1+32.0.0
uuid-2.2.23.0.1
vector_math-2.1.02.1.0
win32-2.0.02.0.0
xdg_directories-0.1.20.2.0
xml-4.5.15.0.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.1.5` on crypto does not support the stable version `3.0.0`, that was published 29 days ago.

When crypto is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions crypto to update the constraint.

The constraint `^0.14.0` on html does not support the stable version `0.15.0`, that was published 20 days ago.

When html is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions html to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

0
likes
80
pub points
86%
popularity

A Flutter widget for rendering static matrix html tags as Flutter widgets. (Will render over 70 different html tags!)

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

mail@sorunome.de

License

MIT (LICENSE)

Dependencies

cached_network_image, crypto, flutter, flutter_highlight, flutter_math, highlight, html, isolate, matrix_link_text

More

Packages that depend on flutter_matrix_html