flutter_lab 0.1.3 copy "flutter_lab: ^0.1.3" to clipboard
flutter_lab: ^0.1.3 copied to clipboard

Flutter package for FlutterLab, a UI design tool. Quickly change the parameters of widgets (color, size, alignment, padding, position, opacity, etc.)

6
likes
110/ 140
pub points
61%
popularity

We analyzed this package 5 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

15 out of 126 API elements (11.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: flutter_lab, flutter_lab.FlutterLab.child, flutter_lab.FlutterLab.enabled, flutter_lab.LabAlign, flutter_lab.LabAlign.LabAlign.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:flutter_lab/flutter_lab.dart that imports:
  • package:flutter_lab/src/widgets/text.dart that imports:
  • package:flutter_lab/src/_widgets.dart that imports:
  • package:flutter_lab/src/mixin.dart that imports:
  • package:flutter_lab/src/lab.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

INFO: 'textScaleFactor' is deprecated and shouldn't be used. Use textScaler instead. Use of textScaleFactor was deprecated in preparation for the upcoming nonlinear text scaling support. This feature was deprecated after v3.12.0-2.0.pre.

lib/src/widgets/text.dart:235:13

    ╷
235 │             textScaleFactor: textScaleFactor,
    │             ^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/text.dart

lib/src/data_provider.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
cupertino_icons any 1.0.8 1.0.8
flutter flutter 0.0.0 0.0.0
get_it any 7.7.0 7.7.0
google_fonts any 6.2.1 6.2.1
socket_io_client ^1.0.2 1.0.2 2.0.3+1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
http - 1.2.1 1.2.1
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
path_provider - 2.1.3 2.1.3
path_provider_android - 2.2.4 2.2.4
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
socket_io_common - 1.0.1 2.0.3
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.5.1 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.2` on socket_io_client does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions socket_io_client to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

6
likes
110
pub points
61%
popularity

Publisher

verified publisherflutterlab.dev

Flutter package for FlutterLab, a UI design tool. Quickly change the parameters of widgets (color, size, alignment, padding, position, opacity, etc.)

Repository (GitHub)
View/report issues

Topics

#ui #widget #tool

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

cupertino_icons, flutter, get_it, google_fonts, socket_io_client

More

Packages that depend on flutter_lab