firebase_auth_simplify 1.2.0

Flutter Android iOS

A high-level framework of Firebase Auth package that wraps several lines of codes to one line in order to easily use sign-in and out function.

9
likes
80 / 110
pub points
65 %
popularity

We analyzed this package on Sep 27, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 75 API elements (9.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:firebase_auth_simplify/firebase_auth_simplify.dart that imports:
  • package:firebase_auth_simplify/src/api/firebase_apple_auth_api.dart that imports:
  • package:apple_sign_in/apple_sign_in.dart that declares support for platforms: Android, iOS

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:firebase_auth_simplify/firebase_auth_simplify.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS, macOS, Web
Package does not support Flutter platform Linux

Because:

  • package:firebase_auth_simplify/firebase_auth_simplify.dart that imports:
  • package:firebase_auth/firebase_auth.dart that declares support for platforms: Android, iOS, macOS, Web
Package does not support Flutter platform macOS

Because:

  • package:firebase_auth_simplify/firebase_auth_simplify.dart that imports:
  • package:firebase_auth_simplify/src/api/firebase_apple_auth_api.dart that imports:
  • package:apple_sign_in/apple_sign_in.dart that declares support for platforms: Android, iOS

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support Flutter platform Android

Because:

  • package:firebase_auth_simplify/firebase_auth_simplify.dart that imports:
  • package:firebase_auth_simplify/src/api/firebase_kakao_auth_api.dart that imports:
  • package:kakao_flutter_sdk/user.dart that imports:
  • package:kakao_flutter_sdk/src/user/model/shipping_addresses.dart that imports:
  • package:kakao_flutter_sdk/src/user/model/shipping_address.dart that imports:
  • package:kakao_flutter_sdk/common.dart that imports:
  • package:kakao_flutter_sdk/src/common/util.dart that imports:
  • package:kakao_flutter_sdk/story.dart that imports:
  • package:kakao_flutter_sdk/src/story/story_api.dart that imports:
  • package:kakao_flutter_sdk/src/common/api_factory.dart that imports:
  • package:kakao_flutter_sdk/auth.dart that imports:
  • package:kakao_flutter_sdk/src/auth/access_token_interceptor.dart that imports:
  • package:kakao_flutter_sdk/src/auth/auth_api.dart that imports:
  • package:kakao_flutter_sdk/src/auth/access_token_store.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Package does not support Flutter platform iOS

Because:

  • package:firebase_auth_simplify/firebase_auth_simplify.dart that imports:
  • package:firebase_auth_simplify/src/api/firebase_kakao_auth_api.dart that imports:
  • package:kakao_flutter_sdk/user.dart that imports:
  • package:kakao_flutter_sdk/src/user/model/shipping_addresses.dart that imports:
  • package:kakao_flutter_sdk/src/user/model/shipping_address.dart that imports:
  • package:kakao_flutter_sdk/common.dart that imports:
  • package:kakao_flutter_sdk/src/common/util.dart that imports:
  • package:kakao_flutter_sdk/story.dart that imports:
  • package:kakao_flutter_sdk/src/story/story_api.dart that imports:
  • package:kakao_flutter_sdk/src/common/api_factory.dart that imports:
  • package:kakao_flutter_sdk/auth.dart that imports:
  • package:kakao_flutter_sdk/src/auth/access_token_interceptor.dart that imports:
  • package:kakao_flutter_sdk/src/auth/auth_api.dart that imports:
  • package:kakao_flutter_sdk/src/auth/access_token_store.dart that imports:
  • package:shared_preferences/shared_preferences.dart that imports:
  • package:shared_preferences_windows/shared_preferences_windows.dart that declares support for platforms: Windows
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
apple_sign_in^0.1.00.1.00.1.0
cloud_functions^0.5.00.5.00.6.0
firebase_analytics^5.0.105.0.166.0.0
firebase_auth^0.16.00.16.10.18.0+1
flutterflutter0.0.00.0.0
flutter_facebook_login^3.0.03.0.03.0.0
google_sign_in^4.5.14.5.44.5.4
http^0.12.0+40.12.20.12.2
kakao_flutter_sdk^0.4.20.4.20.5.0
provider^4.3.14.3.2+24.3.2+2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.0.01.0.0
charcode-1.1.31.1.3
cloud_functions_platform_interface-1.1.02.0.0
cloud_functions_web-1.1.02.0.0
collection-1.14.131.14.13
dio-3.0.103.0.10
ffi-0.1.30.1.3
file-5.2.15.2.1
firebase-7.3.07.3.0
firebase_analytics_platform_interface-1.0.31.0.3
firebase_analytics_web-0.1.10.1.1
firebase_auth_platform_interface-1.1.82.0.1
firebase_auth_web-0.1.3+10.3.0+1
firebase_core-0.4.50.5.0
firebase_core_platform_interface-1.0.42.0.0
firebase_core_web-0.1.1+20.2.0
flutter_web_plugins-0.0.00.0.0
google_sign_in_platform_interface-1.1.21.1.2
google_sign_in_web-0.9.20.9.2
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.20.6.2
json_annotation-3.1.03.1.0
matcher-0.12.90.12.9
meta-1.1.81.2.3
nested-0.0.40.0.4
package_info-0.4.30.4.3
path-1.7.01.7.0
path_provider_linux-0.0.1+20.0.1+2
path_provider_platform_interface-1.0.31.0.3
path_provider_windows-0.0.4+10.0.4+1
pedantic-1.9.01.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.21.0.2
process-3.0.133.0.13
quiver-2.1.32.1.3
shared_preferences-0.5.120.5.12
shared_preferences_linux-0.0.2+20.0.2+2
shared_preferences_macos-0.0.1+100.0.1+10
shared_preferences_platform_interface-1.0.41.0.4
shared_preferences_web-0.1.2+70.1.2+7
shared_preferences_windows-0.0.1+10.0.1+1
sky_engine-0.0.990.0.99
source_span-1.7.01.7.0
stack_trace-1.9.51.9.5
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0
vector_math-2.0.82.0.8
win32-1.7.31.7.3
xdg_directories-0.1.00.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.5.0` on cloud_functions does not support the latest published version `0.6.0`

pubspec.yaml:14:20

   ╷
14 │   cloud_functions: ^0.5.0
   │                    ^^^^^^
   ╵
The constraint `^5.0.10` on firebase_analytics does not support the latest published version `6.0.0`

pubspec.yaml:15:23

   ╷
15 │   firebase_analytics: ^5.0.10 # Without this, flutter_kakao_login will fail.
   │                       ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

9
likes
80
pub points
65%
popularity

A high-level framework of Firebase Auth package that wraps several lines of codes to one line in order to easily use sign-in and out function.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

asurah4@gmail.com

License

MIT (LICENSE)

Dependencies

apple_sign_in, cloud_functions, firebase_analytics, firebase_auth, flutter, flutter_facebook_login, google_sign_in, http, kakao_flutter_sdk, provider

More

Packages that depend on firebase_auth_simplify