fhir_auth 0.4.1
fhir_auth: ^0.4.1 copied to clipboard

A Dart/Flutter package for authorization & authentication, includes SMART on FHIR and Google sign-in

5
likes
110 / 120
pub points
61 %
popularity

We analyzed this package on Aug 4, 2021, and awarded it 110 pub points (of a possible 120):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/lib/main.dart
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:fhir_auth/dstu2/smart_client/smart_mobile_client.dart that imports:
  • package:flutter_secure_storage/flutter_secure_storage.dart that declares support for platforms: Android, iOS, Linux
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.15.01.15.01.15.0
fhir^0.4.60.4.70.4.7
fhir_at_rest^0.4.20.4.50.4.5
flutterflutter0.0.00.0.0
flutter_appauth^1.0.01.1.01.1.0
flutter_secure_storage^4.2.04.2.14.2.1
flutter_web_pluginsflutter0.0.00.0.0
freezed_annotation^0.14.20.14.20.14.3
google_sign_in^5.0.45.0.75.0.7
http^0.13.30.13.30.13.3
oauth2^2.0.02.0.02.0.0
universal_html^2.0.82.0.82.0.8
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.12.8.1
characters-1.1.01.1.0
charcode-1.3.11.3.1
crypto-3.0.13.0.1
csslib-0.17.00.17.0
fhir_yaml-0.4.20.5.0
flutter_appauth_platform_interface-3.1.03.1.0
google_sign_in_platform_interface-2.0.12.0.1
google_sign_in_web-0.10.0+10.10.0+1
html-0.15.00.15.0
http_parser-4.0.04.0.0
js-0.6.30.6.3
json_annotation-4.0.14.1.0
matcher-0.12.100.12.10
meta-1.3.01.7.0
path-1.8.01.8.0
plugin_platform_interface-2.0.12.0.1
quiver-3.0.13.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
universal_io-2.0.42.0.4
vector_math-2.1.02.1.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.