feed 0.5.21 copy "feed: ^0.5.21" to clipboard
feed: ^0.5.21 copied to clipboard

A package for managing load more lists and sliding sheets.

0
likes
100/ 140
pub points
33%
popularity

We analyzed this package 5 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

309 out of 772 API elements (40.0 %) have documentation comments.

Some symbols that are missing documentation: Feed, animation_system_delegate_builder, animation_system_delegate_builder.AnimationSystemController, animation_system_delegate_builder.AnimationSystemController.AnimationSystemController, animation_system_delegate_builder.AnimationSystemController.isBinded.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:feed/feed.dart that imports:
  • package:feed/animationSystem/simulation_system_delegate_builder.dart that imports:
  • package:fort/fort.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:feed/feed.dart that imports:
  • package:feed/animationSystem/simulation_system_delegate_builder.dart that imports:
  • package:fort/fort.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:feed/feed.dart that imports:
  • package:feed/animationSystem/simulation_system_delegate_builder.dart that imports:
  • package:fort/fort.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:feed/feed.dart that imports:
  • package:feed/animationSystem/simulation_system_delegate_builder.dart that imports:
  • package:fort/fort.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 95 issues. Showing the first 2:

WARNING: Duplicate export.

lib/feed.dart:12:8

   ╷
12 │ export 'package:feed/util/icon_position.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/feed.dart

WARNING: The value of the field 'FLING_DURATION' isn't used.

lib/swipeCard/swipe_card.dart:123:25

    ╷
123 │   static const Duration FLING_DURATION = Duration(milliseconds: 300); 
    │                         ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/swipeCard/swipe_card.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
connectivity ^3.0.6 3.0.6 3.0.6
figma_squircle ^0.5.3 0.5.3 0.5.3
flutter flutter 0.0.0 0.0.0
flutter_bloc ^7.2.0 7.3.3 8.1.4
flutter_keyboard_visibility ^5.0.3 5.4.1 6.0.0
flutter_neumorphic_null_safety ^3.2.4 3.2.4 3.2.4
flutter_staggered_grid_view ^0.4.0 0.4.1 0.7.0
flutter_svg ^0.22.0 0.22.0 2.0.10+1
fort 0.1.2 0.1.2 0.1.3
perceive_slidable ^0.1.0 0.1.0 0.1.0
tuple ^2.0.0 2.0.2 2.0.2
Transitive dependencies
Package Constraint Compatible Latest
bloc - 7.2.1 8.1.3
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
connectivity_for_web - 0.4.0+1 0.4.0+1
connectivity_macos - 0.2.1+2 0.2.1+2
connectivity_platform_interface - 2.0.1 2.0.1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_keyboard_visibility_linux - 1.0.0 1.0.0
flutter_keyboard_visibility_macos - 1.0.0 1.0.0
flutter_keyboard_visibility_platform_interface - 2.0.0 2.0.0
flutter_keyboard_visibility_web - 2.0.0 2.0.0
flutter_keyboard_visibility_windows - 1.0.0 1.0.0
flutter_redux - 0.8.2 0.10.0
flutter_web_plugins - 0.0.0 0.0.0
hive - 2.2.3 2.2.3
hive_flutter - 1.1.0 1.1.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
nested - 1.0.0 1.0.0
path - 1.9.0 1.9.0
path_drawing - 0.5.1+1 1.0.1
path_parsing - 0.2.1 1.0.1
path_provider - 2.1.2 2.1.2
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 5.4.0 6.0.2
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
provider - 6.1.2 6.1.2
redux - 5.0.0 5.0.0
redux_persist - 0.9.0 0.9.0
redux_persist_flutter - 0.9.0 0.9.0
redux_thunk - 0.4.0 0.4.0
shared_preferences - 2.2.2 2.2.2
shared_preferences_android - 2.2.1 2.2.1
shared_preferences_foundation - 2.3.5 2.3.5
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
synchronized - 3.1.0+1 3.1.0+1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
web - 0.5.0 0.5.0
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4
xml - 5.4.1 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^7.2.0` on flutter_bloc does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions flutter_bloc to update the constraint.

The constraint `^5.0.3` on flutter_keyboard_visibility does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions flutter_keyboard_visibility to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.