event_tracker 0.0.4 copy "event_tracker: ^0.0.4" to clipboard
event_tracker: ^0.0.4 copied to clipboard

The Lemnisk Flutter SDK allows you to track user event data from your Android app. The SDK can be easily imported into any Android or iOS app. Based on the data it receives from the user activity, it [...]

0
likes
100/ 160
pub points
22%
popularity

We analyzed this package 32 hours ago, and awarded it 100 pub points (of a possible 160):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/yesvcan/event-tracker was unreachable. Make sure that the website is reachable via HEAD requests.

Repository URL doesn't exist.

At the time of the analysis https://github.com/yesvcan/event-tracker was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: event_tracker,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

9 out of 76 API elements (11.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: AppConstants, AppConstants.AppConstants, AppConstants.AppConstants.AppConstants, AppConstants.AppConstants.BASEURL, AppConstants.AppConstants.analyze_request.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:event_tracker/event_tracker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:event_tracker/event_tracker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:event_tracker/event_tracker.dart that declares support for platforms: Android, iOS, Web.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 24 issues. Showing the first 2:

WARNING: The '?' is unnecessary because 'dynamic' is nullable without it.

lib/LemniskFlutterIdentifier.dart:34:14

   ╷
34 │       dynamic? googleAdvertisingBool;
   │              ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/LemniskFlutterIdentifier.dart

WARNING: The '?' is unnecessary because 'dynamic' is nullable without it.

lib/LemniskFlutterScreen.dart:34:14

   ╷
34 │       dynamic? googleAdvertisingBool;
   │              ^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/LemniskFlutterScreen.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
advertising_id ^2.1.1 2.6.0 2.6.0
appsflyer_sdk ^6.4.0+2 6.14.3 6.14.3
date_time_format ^2.0.1 2.0.1 2.0.1
device_info ^2.0.0 2.0.3 2.0.3
firebase_analytics ^9.0.4 9.3.8 11.0.1
firebase_core ^1.10.6 1.24.0 3.1.0
firebase_messaging ^11.2.4 11.4.4 15.0.1
flutter flutter 0.0.0 0.0.0
flutter_screenutil ^5.0.1+2 5.9.3 5.9.3
flutter_web_plugins flutter 0.0.0 0.0.0
http ^0.13.3 0.13.6 1.2.1
package_info_plus ^1.0.6 1.4.3+1 8.0.0
platform_device_id_platform_interface ^1.0.0 1.0.0 1.0.0
shared_preferences ^2.0.6 2.2.3 2.2.3
Transitive dependencies
Package Constraint Compatible Latest
_flutterfire_internals - 1.0.2 1.3.37
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
cloud_firestore_platform_interface - 5.7.7 6.2.7
cloud_firestore_web - 2.8.10 4.0.1
collection - 1.18.0 1.19.0
device_info_platform_interface - 2.0.1 2.0.1
fake_async - 1.3.1 1.3.1
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
firebase_analytics_platform_interface - 3.3.7 4.0.1
firebase_analytics_web - 0.4.2+7 0.5.7+9
firebase_core_platform_interface - 4.8.0 5.1.0
firebase_core_web - 1.7.3 2.17.2
firebase_messaging_platform_interface - 3.5.4 4.5.39
firebase_messaging_web - 2.4.4 3.8.9
flutter_test - 0.0.0 0.0.0
http_parser - 4.0.2 4.1.0
js - 0.6.7 0.7.1
leak_tracker - 10.0.4 10.0.5
leak_tracker_flutter_testing - 3.0.3 3.0.5
leak_tracker_testing - 3.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
package_info_plus_linux - 1.0.5 2.0.0
package_info_plus_macos - 1.3.0 2.0.0
package_info_plus_platform_interface - 1.0.2 3.0.0
package_info_plus_web - 1.0.6 2.0.0
package_info_plus_windows - 2.1.0 3.0.0
path - 1.9.0 1.9.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
shared_preferences_android - 2.2.3 2.2.3
shared_preferences_foundation - 2.4.0 2.4.0
shared_preferences_linux - 2.3.2 2.3.2
shared_preferences_platform_interface - 2.3.2 2.3.2
shared_preferences_web - 2.3.0 2.3.0
shared_preferences_windows - 2.3.2 2.3.2
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.2
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
vm_service - 14.2.1 14.2.4
web - 0.5.1 0.5.1
win32 - 3.1.4 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^9.0.4` on firebase_analytics does not support the stable version `10.0.0`.

Try running dart pub upgrade --major-versions firebase_analytics to update the constraint.

The constraint `^1.10.6` on firebase_core does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions firebase_core to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

0
likes
100
pub points
22%
popularity

Publisher

unverified uploader

The Lemnisk Flutter SDK allows you to track user event data from your Android app. The SDK can be easily imported into any Android or iOS app. Based on the data it receives from the user activity, it sends real-time personalized push notifications to the users about the services and products that our clients provide.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

advertising_id, appsflyer_sdk, date_time_format, device_info, firebase_analytics, firebase_core, firebase_messaging, flutter, flutter_screenutil, flutter_web_plugins, http, package_info_plus, platform_device_id_platform_interface, shared_preferences

More

Packages that depend on event_tracker