ejdb2_dart 1.0.62
ejdb2_dart: ^1.0.62 copied to clipboard

Dart native

Embeddable JSON Database engine EJDB http://ejdb.org Dart binding

2
likes
90 / 110
pub points
16 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 42 out of 65 API elements (64.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:ejdb2_dart/ejdb2_dart.dart that imports:
  • dart:nativewrappers
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/ejdb2_dart.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
json_at^1.0.21.0.41.0.4
path^1.6.21.8.01.8.0
quiver^2.0.32.1.53.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-17.0.017.0.0
analyzer-1.1.01.1.0
args-2.0.02.0.0
async-2.5.02.5.0
boolean_selector-2.1.02.1.0
charcode-1.2.01.2.0
cli_util-0.3.00.3.0
collection-1.15.01.15.0
convert-3.0.03.0.0
coverage-1.0.11.0.1
crypto-3.0.03.0.0
file-6.1.06.1.0
glob-2.0.02.0.0
http_multi_server-3.0.03.0.0
http_parser-4.0.04.0.0
io-1.0.01.0.0
js-0.6.30.6.3
logging-1.0.01.0.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-1.0.01.0.0
node_preamble-1.4.132.0.0
package_config-2.0.02.0.0
pedantic-1.11.01.11.0
pool-1.5.01.5.0
pub_semver-2.0.02.0.0
shelf-1.0.01.0.0
shelf_packages_handler-3.0.03.0.0
shelf_static-1.0.01.0.0
shelf_web_socket-1.0.01.0.0
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test-1.16.51.16.5
test_api-0.2.190.2.19
test_core-0.3.150.3.15
typed_data-1.3.01.3.0
vm_service-6.1.0+16.1.0+1
watcher-1.0.01.0.0
web_socket_channel-2.0.02.0.0
webkit_inspection_protocol-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.3` on quiver does not support the stable version `3.0.0`, that was published 14 days ago.

When quiver is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions quiver to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Dart 2.12.0.

2
likes
90
pub points
16%
popularity

Publisher

ejdb.org

Embeddable JSON Database engine EJDB http://ejdb.org Dart binding

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

json_at, path, quiver

More

Packages that depend on ejdb2_dart