ejdb2_dart 1.0.61
ejdb2_dart: ^1.0.61

Dart native

Embeddable JSON Database engine EJDB http://ejdb.org Dart binding

example/example.dart

import 'package:ejdb2_dart/ejdb2_dart.dart';

void main() async {
  final db = await EJDB2.open('example.db', truncate: true);

  var id = await db.put('parrots', {'name': 'Bianca', 'age': 4});
  print('Bianca record: ${id}');

  id = await db.put('parrots', {'name': 'Darko', 'age': 8});
  print('Darko record: ${id}');

  final q = db.createQuery('/[age > :age]', 'parrots');
  await for (final doc in q.setInt('age', 3).execute()) {
    print('Found $doc');
  }
  await db.close();
}
2
likes
90
pub points
40%
popularity

Publisher

ejdb.org

Embeddable JSON Database engine EJDB http://ejdb.org Dart binding

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

json_at, path, quiver

More

Packages that depend on ejdb2_dart