ejdb2_dart 1.0.57

Dart native

Embeddable JSON Database engine EJDB http://ejdb.org Dart binding

ejdb_dart (1.0.57)

  • Upgraded to ejdb v2.0.50

ejdb_dart (1.0.56)

  • Upgraded to ejdb v2.0.49

ejdb_dart (1.0.55)

  • Upgraded to ejdb v2.0.48 (Support of collection Joins)

ejdb_dart (1.0.54)

  • Upgraded to ejdb v2.0.47

ejdb_dart (1.0.53)

  • Upgraded to ejdb v2.0.46

ejdb_dart (1.0.52)

  • Upgraded to ejdb v2.0.45

ejdb_dart (1.0.51)

  • Upgraded to ejdb v2.0.44

ejdb_dart (1.0.50)

  • Upgraded to ejdb v2.0.43

ejdb_dart (1.0.49)

  • Upgraded to ejdb v2.0.42

ejdb_dart (1.0.48)

  • Updated to the latest dart_api.h dart v2.8.x

ejdb_dart (1.0.47)

  • Upgraded to ejdb v2.0.41

ejdb_dart (1.0.46)

  • Upgraded to ejdb v2.0.40

ejdb_dart (1.0.45)

  • Upgraded to ejdb v2.0.39

ejdb_dart (1.0.44)

  • Upgraded to ejdb v2.0.37
  • Fixed wal related durability issue

ejdb_dart (1.0.43)

  • Upgraded to ejdb2 v1.3.36

ejdb_dart (1.0.42)

  • Fixed JQL apply ignores value set by placeholder #269

ejdb_dart (1.0.41)

  • Added patchOrPut()

ejdb_dart (1.0.40)

  • Added delIgnoreNotFound()

ejdb_dart (1.0.39)

  • Upgraded to ejdb2 v1.3.32

ejdb_dart (1.0.38)

  • Upgraded to ejdb v2.0.31

ejdb_dart (1.0.37)

  • Upgraded to ejdb v2.0.30

ejdb_dart (1.0.36)

  • Now supports online backups
  • Upgraded to ejdb v2.0.29

ejdb_dart (1.0.35)

  • Upgraded to ejdb v2.0.28

ejdb_dart (1.0.34+2)

  • Upgraded to iowow v1.3.25 with critical fixes

ejdb_dart (1.0.33)

  • Upgraded to ejdb v2.0.26

ejdb_dart (1.0.32)

  • Fixed memory leak in dart binding

ejdb_dart (1.0.31)

  • Fixed missing native libejdb2dart.so

ejdb_dart (1.0.30)

  • Upgraded to ejdb v2.0.23

ejdb_dart (1.0.29)

  • Upgraded to ejdb v2.0.22

ejdb_dart (1.0.28)

  • Added async messages backpressure during query execution. (#255)

ejdb_dart (1.0.27)

  • Added EJDB2.rename(oldCollectionName, newCollectionName) method. (#254)

ejdb_dart (1.0.26)

  • Added JBDOC[] operator which is equivalent of JBDOC.at(pointer)

ejdb_dart (1.0.25)

  • Typo fixed

ejdb_dart (1.0.24)

  • Added JBDOC.at(pointer) to get subset of document using RFC 6901 JSON pointer
  • Added JBDOC.object to access parsed JSON document body

ejdb_dart (1.0.23)

  • Upgraded to ejdb v2.0.20
  • Minor fixes in docs
  • Set proper query limit in JQL.first and JQL.firstN

ejdb_dart (1.0.22)

  • Upgraded to ejdb v2.0.19 / iowow v1.3.20 with critical fixes

ejdb_dart (1.0.21)

  • Upgraded to ejdb v2.0.18

ejdb_dart (1.0.20)

  • Added inverse JQL query option. (ejdb 2.0.17)

ejdb_dart (1.0.19)

  • Upgraded to ejdb v2.0.16

ejdb_dart (1.0.18)

  • Security: a heap-overflow vulnerability was fixed in the WebSocket parser of facil.io library

ejdb_dart (1.0.17)

  • Added convenient JQL#firstRequired()

ejdb_dart (1.0.16)

  • Upgraded to ejdb2_2.0.13 with critical fixes

ejdb_dart (1.0.15)

  • Upgraded to ejdb2_2.0.12 with critical fixes

ejdb_dart (1.0.14)

  • Upgraded to ejdb2_2.0.11 with critical fixes

ejdb_dart (1.0.13)

  • CRITICAL: Fixed unexpected database file truncation and data loss on close.
  • Upgraded to iowow 1.3.14

ejdb_dart (1.0.12)

  • Added query limit override in JQL#execute
  • Added native JQL#limit getter

ejdb_dart (1.0.11)

  • Added JQL#firstOrNull() and JQL#firstN() with relevant test cases
  • Build fixes: HTTP/WS server was not included in 1.0.10

ejdb_dart (1.0.10)

  • Upgrade to ejdb 2.0.9 release

ejdb_dart (1.0.9)

  • Ability to log query execution plan with explainCallback function in JQL#execute() and JQL#scalarInt()

ejdb_dart (1.0.8)

  • Added notFound,invalidQuery to EJDB2Error

ejdb_dart (1.0.7)

  • Updated to ejdb v2.0.8

ejdb_dart (1.0.6)

  • Updated to ejdb v2.0.7
    • Fixed deadlock condition with OSX pthread rwlocks.
    • Phreads PTHREAD_RWLOCK_PREFER_WRITER_NONRECURSIVE_NP is used by default

ejdb_dart (1.0.5)

  • Fix compilation warning: incompatible pointer types passing 'intptr_t *'

ejdb_dart (1.0.4)

  • Updated to ejdb v2.0.6
  • Documentation minors

ejdb_dart (1.0.3)

  • Safe database release in ejdb2_isolate_shared_release()

ejdb_dart (1.0.2)

  • Canonicalize database file path before opening database.

ejdb_dart (1.0.1)

  • Added support of database access from multiple isolates #241

ejdb_dart (1.0.0)

  • Initial version.
2
likes
90
pub points
38%
popularity

Publisher

ejdb.org

Embeddable JSON Database engine EJDB http://ejdb.org Dart binding

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

json_at, path, quiver

More

Packages that depend on ejdb2_dart