dswitch 4.6.0 icon indicating copy to clipboard operation
dswitch: ^4.6.0 copied to clipboard

DSwitch is a cli tool that allows you to rapidly switch between channels and versions of Dart. You can also pin a channel to a specific version.

8
likes
130/ 140
pub points
20%
popularity

We analyzed this package 15 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 2 API elements (50.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^3.1.23.3.53.3.5
args^2.1.12.3.12.3.1
dcli1.21.121.21.121.36.0
dcli_core1.21.121.21.121.36.0
meta^1.0.01.8.01.8.0
path^1.0.01.8.31.8.3
pub_semver^2.0.02.1.32.1.3
pubspec^2.0.12.3.02.3.0
scope^3.0.03.0.03.0.0
settings_yaml^3.5.13.5.15.0.0
system_info^1.0.01.0.11.0.1
win322.0.52.0.53.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
basic_utils-3.9.45.4.2
chunked_stream-1.4.11.4.1
circular_buffer-0.9.10.11.0
collection-1.17.01.17.0
convert-3.1.13.1.1
crypto-3.0.23.0.2
csv-5.0.15.0.1
dart_console-1.0.01.1.2
equatable-2.0.52.0.5
ffi-1.2.12.0.1
file-6.1.46.1.4
file_utils-1.0.11.0.1
glob-2.1.12.1.1
globbing-1.0.01.0.0
http-0.13.50.13.5
http_parser-4.0.24.0.2
ini-2.1.02.1.0
js-0.6.50.6.5
json_annotation-4.7.04.7.0
logging-1.1.01.1.0
matcher-0.12.130.12.13
mime-1.0.31.0.3
pointycastle-3.6.23.6.2
posix-2.2.34.1.0
quiver-3.1.03.1.0
random_string-2.3.12.3.1
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stacktrace_impl-2.3.02.3.0
string_scanner-1.2.01.2.0
system_info2-2.0.42.0.4
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uri-1.0.01.0.0
uuid-3.0.73.0.7
validators2-3.0.03.0.0
vin_decoder-0.2.1-nullsafety0.2.1-nullsafety
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint 1.21.12 on dcli does not support the stable version 1.30.0.

Try running dart pub upgrade --major-versions dcli to update the constraint.

The constraint 1.21.12 on dcli_core does not support the stable version 1.30.0.

Try running dart pub upgrade --major-versions dcli_core to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Dart 2.18.4.

8
likes
130
pub points
20%
popularity

Publisher

verified publisher icononepub.dev

DSwitch is a cli tool that allows you to rapidly switch between channels and versions of Dart. You can also pin a channel to a specific version.

Homepage
Repository (GitHub)

Documentation

Documentation
API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

archive, args, dcli, dcli_core, meta, path, pub_semver, pubspec, scope, settings_yaml, system_info, win32

More

Packages that depend on dswitch