dereference 1.0.10
dereference: ^1.0.10 copied to clipboard

A sample command-line application.

0
likes
100/ 130
pub points
0%
popularity

We analyzed this package 34 hours ago, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dcli^1.7.11.14.11.14.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-3.1.63.1.6
args-2.3.02.3.0
async-2.8.22.8.2
basic_utils-3.9.13.9.1
charcode-1.3.11.3.1
chunked_stream-1.4.11.4.1
circular_buffer-0.10.00.10.0
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
csv-5.0.15.0.1
dart_console-1.0.01.0.0
dcli_core-0.0.40.0.4
equatable-2.0.32.0.3
ffi-1.1.21.1.2
file-6.1.26.1.2
glob-2.0.22.0.2
http-0.13.40.13.4
http_parser-4.0.04.0.0
ini-2.1.02.1.0
js-0.6.30.6.3
json_annotation-4.4.04.4.0
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-1.0.11.0.1
path-1.8.01.8.0
pointycastle-3.4.03.4.0
posix-2.2.22.2.2
pub_semver-2.1.02.1.0
pubspec-2.0.12.0.1
quiver-3.0.1+13.0.1+1
random_string-2.3.12.3.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stacktrace_impl-2.2.12.2.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uri-1.0.01.0.0
uuid-3.0.53.0.5
validators2-3.0.03.0.0
vin_decoder-0.2.1-nullsafety0.2.1-nullsafety
win32-2.3.12.3.1
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.

0
likes
100
pub points
0%
popularity

A sample command-line application.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

dcli

More

Packages that depend on dereference