dcli 1.30.2 icon indicating copy to clipboard operation
dcli: ^1.30.2 copied to clipboard

Dart console SDK - write console (cli) apps/scripts using dart.

115
likes
120/ 130
pub points
86%
popularity

We analyzed this package 23 hours ago, and awarded it 120 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 785 out of 856 API elements (91.7 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:dcli/dcli.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Windows

Because:

  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • dart:cli
Package does not support platform `Linux`.

Because:

  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib-win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/terminal.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib-win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: A value for optional parameter 'appname' isn't ever given.

lib/src/settings.dart:32:10

   ╷
32 │     this.appname = 'dcli',
   │          ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/settings.dart

lib/src/util/file_permissions.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
archive^3.0.03.3.03.3.0
args^2.0.02.3.12.3.1
async^2.5.02.9.02.9.0
chunked_stream^1.4.11.4.11.4.1
collection^1.15.01.16.01.16.0
convert^3.0.13.0.13.0.1
crypto^3.0.03.0.23.0.2
csv^5.0.15.0.15.0.1
dart_console^1.0.01.0.01.0.0
dcli_core^1.30.21.30.21.30.2
equatable^2.0.02.0.32.0.3
ffi^1.1.11.2.11.2.1
file^6.1.06.1.26.1.2
glob^2.0.02.0.22.0.2
ini^2.1.02.1.02.1.0
logging^1.0.21.0.21.0.2
meta^1.3.01.7.01.7.0
mime^1.0.11.0.21.0.2
path^1.8.01.8.11.8.1
posix^3.1.03.1.03.1.0
pub_semver^2.0.02.1.12.1.1
pubspec^2.0.02.1.02.1.0
scope^2.2.12.2.12.2.1
settings_yaml^3.3.13.4.03.4.0
stacktrace_impl^2.3.02.3.02.3.0
system_info2^2.0.32.0.32.0.3
uuid^3.0.03.0.63.0.6
validators2^3.0.03.0.03.0.0
win32^2.1.02.6.12.6.1
yaml^3.0.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
basic_utils-3.9.44.2.2
charcode-1.3.11.3.1
circular_buffer-0.10.00.11.0
file_utils-1.0.11.0.1
globbing-1.0.01.0.0
http-0.13.40.13.4
http_parser-4.0.04.0.0
js-0.6.40.6.4
json_annotation-4.5.04.5.0
matcher-0.12.110.12.11
pointycastle-3.6.03.6.0
quiver-3.1.03.1.0
random_string-2.3.12.3.1
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
string_scanner-1.1.11.1.1
term_glyph-1.2.01.2.0
typed_data-1.3.11.3.1
uri-1.0.01.0.0
vin_decoder-0.2.1-nullsafety0.2.1-nullsafety

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.12, Dart 2.17.0.