better_player_mat 0.0.3 copy "better_player_mat: ^0.0.3" to clipboard
better_player_mat: ^0.0.3 copied to clipboard

Better player edited for more hls options

1
likes
60/ 160
pub points
0%
popularity

We analyzed this package 34 hours ago, and awarded it 60 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: better_player_mat,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: better_player_mat.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

340 out of 411 API elements (82.7 %) have documentation comments.

Some symbols that are missing documentation: better_player, better_player.BetterPlayer.controller, better_player.BetterPlayer.BetterPlayer.file, better_player.BetterPlayer.BetterPlayer.network, better_player.BetterPlayerAsmsDataHolder.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:better_player_mat/better_player_mat.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:better_player_mat/better_player_mat.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:better_player_mat/better_player_mat.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:better_player_mat/better_player_mat.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:better_player_mat/better_player_mat.dart that imports:
  • package:better_player_mat/src/core/better_player.dart that imports:
  • package:wakelock/wakelock.dart that imports:
  • package:wakelock_macos/wakelock_macos.dart that declares support for platforms: macOS.
Package does not support platform `iOS`.

Because:

  • package:better_player_mat/better_player_mat.dart that imports:
  • package:better_player_mat/src/core/better_player.dart that imports:
  • package:wakelock/wakelock.dart that imports:
  • package:wakelock_macos/wakelock_macos.dart that declares support for platforms: macOS.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

ERROR: The getter 'bodyText1' isn't defined for the type 'TextTheme'.

lib/src/configuration/better_player_controls_configuration.dart:243:34

    ╷
243 │       textColor: theme.textTheme.bodyText1?.color ?? Colors.white,
    │                                  ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/configuration/better_player_controls_configuration.dart

ERROR: The getter 'button' isn't defined for the type 'TextTheme'.

lib/src/configuration/better_player_controls_configuration.dart:244:35

    ╷
244 │       iconsColor: theme.textTheme.button?.color ?? Colors.white,
    │                                   ^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/configuration/better_player_controls_configuration.dart

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.19.0
cupertino_icons ^1.0.4 1.0.8 1.0.8
flutter flutter 0.0.0 0.0.0
flutter_widget_from_html_core ^0.8.4 0.8.5+3 0.15.1
meta ^1.7.0 1.12.0 1.15.0
path_provider ^2.0.8 2.1.3 2.1.3
visibility_detector ^0.2.2 0.2.2 0.4.0+2
wakelock ^0.5.6 0.5.6 0.6.2
xml ^5.3.1 5.4.1 6.5.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
csslib - 0.17.3 1.0.0
ffi - 2.1.2 2.1.2
flutter_web_plugins - 0.0.0 0.0.0
fwfh_text_style - 2.23.8 2.23.8
html - 0.15.4 0.15.4
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.6 2.2.6
path_provider_foundation - 2.4.0 2.4.0
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
petitparser - 5.4.0 6.0.2
platform - 3.1.5 3.1.5
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1
vector_math - 2.1.4 2.1.4
wakelock_macos - 0.4.0 0.4.0
wakelock_platform_interface - 0.3.0 0.3.0
wakelock_web - 0.4.0 0.4.0
wakelock_windows - 0.2.1 0.2.1
win32 - 3.1.4 5.5.1
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.8.4` on flutter_widget_from_html_core does not support the stable version `0.9.0`.

Try running dart pub upgrade --major-versions flutter_widget_from_html_core to update the constraint.

The constraint `^0.2.2` on visibility_detector does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions visibility_detector to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 2 errors:

  • UNDEFINED_GETTER - lib/src/configuration/better_player_controls_configuration.dart:243:34 - The getter 'bodyText1' isn't defined for the type 'TextTheme'.
  • UNDEFINED_GETTER - lib/src/configuration/better_player_controls_configuration.dart:244:35 - The getter 'button' isn't defined for the type 'TextTheme'.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.