atonline_login 0.4.6 icon indicating copy to clipboard operation
atonline_login: ^0.4.6 copied to clipboard

Client-side login page for applications using AtOnline apis and custom realms

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 14 API elements (14.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:atonline_login/atonline_login.dart that imports:
  • package:atonline_login/src/login.dart that imports:
  • package:atonline_login/src/imagepicker.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS, Web.

Package does not support platform Linux.

Because:

  • package:atonline_login/atonline_login.dart that imports:
  • package:atonline_login/src/login.dart that imports:
  • package:atonline_login/src/imagepicker.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS, Web.

Package does not support platform macOS.

Because:

  • package:atonline_login/atonline_login.dart that imports:
  • package:atonline_login/src/login.dart that imports:
  • package:atonline_login/src/imagepicker.dart that imports:
  • package:image_picker/image_picker.dart that declares support for platforms: Android, iOS, Web.

Package not compatible with platform Web

Because:

  • package:atonline_login/atonline_login.dart that imports:
  • package:atonline_login/src/login.dart that imports:
  • package:atonline_login/src/imagepicker.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'launch' is deprecated and shouldn't be used. Use launchUrl instead.

lib/src/login.dart:309:32

    ╷
309 │                   onTap: () => launch(info["link"]),
    │                                ^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/login.dart

INFO: 'launch' is deprecated and shouldn't be used. Use launchUrl instead.

lib/src/login.dart:382:40

    ╷
382 │                           onTap: () => launch(info["link"]),
    │                                        ^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/login.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
atonline_api^0.4.80.4.120.4.12
crypto^3.0.13.0.23.0.2
flutterflutter0.0.00.0.0
flutter_svg^1.0.31.1.61.1.6
flutter_web_auth^0.4.00.4.30.5.0
image_picker^0.8.4+20.8.60.8.6
url_launcher^6.0.126.1.76.1.7
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
clock-1.1.11.1.1
collection-1.16.01.17.0
cross_file-0.3.3+20.3.3+2
flutter_localizations-0.0.00.0.0
flutter_plugin_android_lifecycle-2.0.72.0.7
flutter_secure_storage-5.1.26.1.0
flutter_secure_storage_linux-1.1.21.1.2
flutter_secure_storage_macos-1.1.21.1.2
flutter_secure_storage_platform_interface-1.0.11.0.1
flutter_secure_storage_web-1.1.11.1.1
flutter_secure_storage_windows-1.1.31.1.3
flutter_web_plugins-0.0.00.0.0
http-0.13.50.13.5
http_parser-4.0.24.0.2
image_picker_android-0.8.5+30.8.5+3
image_picker_for_web-2.1.102.1.10
image_picker_ios-0.8.6+10.8.6+1
image_picker_platform_interface-2.6.22.6.2
intl-0.17.00.17.0
js-0.6.40.6.5
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
mime-1.0.31.0.3
path-1.8.21.8.2
path_drawing-1.0.11.0.1
path_parsing-1.0.11.0.1
petitparser-5.1.05.1.0
plugin_platform_interface-2.1.32.1.3
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
uni_links-0.5.10.5.1
uni_links_platform_interface-1.0.01.0.0
uni_links_web-0.1.00.1.0
url_launcher_android-6.0.226.0.22
url_launcher_ios-6.0.176.0.17
url_launcher_linux-3.0.13.0.1
url_launcher_macos-3.0.13.0.1
url_launcher_platform_interface-2.1.12.1.1
url_launcher_web-2.0.132.0.13
url_launcher_windows-3.0.13.0.1
vector_math-2.1.22.1.4
xml-6.1.06.2.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^0.4.0 on flutter_web_auth does not support the stable version 0.5.0, that was published 27 days ago.

When flutter_web_auth is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_web_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

0
likes
100
pub points
0%
popularity

Publisher

verified publisher iconatonline.com

Client-side login page for applications using AtOnline apis and custom realms

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

atonline_api, crypto, flutter, flutter_svg, flutter_web_auth, image_picker, url_launcher

More

Packages that depend on atonline_login